Planetside Software Forums

Support => Terragen Support => Topic started by: Sam_Zen on July 29, 2008, 11:47:38 pm

Title: No run in XP
Post by: Sam_Zen on July 29, 2008, 11:47:38 pm
Hi all,

I'm new to this forum, but not a newbie with Terragen. I started using it with
Latest years I've run it on Win2K successfully. v Then the hardware seriously broke down.
I got a new machine with XP Home SP1 on it.
So now I"m busy installing all my applications again on the set, including of course Terragen.
This failed. I suspect a dll or ocx is missing.
Any idea about the direction I have to search to get this solved ?
Title: Re: No run in XP
Post by: PG on July 30, 2008, 02:13:11 pm
Do any error messages pop up regarding an OCX or DLL? if so just google search the name, there's a ton of OCX resources online and some, although not as many, DLL resources.
Title: Re: No run in XP
Post by: Sam_Zen on July 30, 2008, 09:17:19 pm
Thanks. I already did that. The popup said :
QuoteComponent 'comctl32.ocx', or one of its dependencies not correctly registered: a file is missing or invalid

So I dug up this .ocx-file from my archive, and copied it into the System32 directory (where it indeed lacked). But it didn't help.
Its dependencies ? Vague.
And what does 'not correctly registered' means ? It's not enough to copy the file, but it has to be installed in some way ?
Another suspicion I have is about user rights. Since XP this has become far more complicated about the permissions what to do.
I already had 'tginstall0943.msi' in my archive, but I DL'd it again, to be sure to be up to date. Didn't work either.
So far, I installed TG not in the default Program Files, but in a more appropriate directory. Relevant ? I dunno.
Title: Re: No run in XP
Post by: PG on July 31, 2008, 02:32:51 pm
Any program that is built on windowsNT should take any references straight from system32.bin, this is how games are made portable to gamers who don't have the DirectXSDK even though the developers use it so installing the program, even on another hard drive won't matter. Are you running the main account (administrator) on the computer? If you are then XP won't interfere, the only thing I could suggest is using recovery discs to run a repair of XP.
Title: Re: No run in XP
Post by: Sam_Zen on July 31, 2008, 10:48:01 pm
Well, this is the last thing I want to do, since I'm still building my toolbox again.
I installed the latest DirectX in the meantime, so that shouldn't be a problem.
I'm running the main account, because I'm the only one.
But maybe this is something, because so far, during the install process, I chose for 'every user' in the dialog.
I must say, that I don't like the growing aspect of 'user rights' since XP. It's causing a lot of trouble with a lot of apps.
Title: Re: No run in XP
Post by: PG on August 01, 2008, 02:19:25 pm
Well I only used DirectX as an example, it won't affect TG. Try running the program in compatibility mode set to whichever operating system you were using before you installed xp. (Compatibility mode is in the properties page, when you right click the TG icon properties is at the bottom. I expect you know that but just in case.)
Title: Re: No run in XP
Post by: Sam_Zen on August 02, 2008, 10:36:25 pm
I just succeeded in making work Terragen correctly. Which generates quite some answers on questions as well.
Warning messages about missing drivers were not there. I installed 2 times, one as every user, one only for my rights. No difference.
So both these aspects weren't the problem.

The difference was made by the choice of the directory Terragen should go into.
On the W2K set I was used to have Terragen installed in a dedicated "terrain" subdir on another partition.
Now, I have only one partition, but I still tried to install TG in such a subdir so far.
This time, I let the setup-procedure do its default ways, so TG ends up in the Program Files directory. And then it works..

I'm very happy of course. :)
On the other hand, I wonder. Is this path-restriction a buggy behaviour, or is this still due to the XP organization ?
Title: Re: No run in XP
Post by: PG on August 03, 2008, 02:21:38 pm
It's weird. I have XP and Vista, one on each of my hard drives and I install games that have DirectX 10 on vista but if I want to play them on XP for compatibility or just because I can't be bothered to switch to vista then I just install the program again but use the Vista install directory so it just uses the vista installation with the registry entries in XP and I've never had a problem doing that.
Title: Re: No run in XP
Post by: Oshyan on August 12, 2008, 01:21:21 am
There should not be any limitation in terms of where you can install Terragen to. If it worked under Win2k you can expect that it was not a change in Terragen but a change in the way the OS works. It may have something to do with how the OS setup allows (or disallows) DLL registration/installation.

In any case it's good that you got it working. Now you may try copying the folder to the location you wish to use it from and see if double-clicking the .exe in the folder will still allow it to run. If so you may make a shortcut to it and use this for your Terragen install, if you strongly prefer it to be in a location besides the default.

- Oshyan
Title: Re: No run in XP
Post by: Sam_Zen on August 13, 2008, 09:49:51 pm
Great. Thanks a lot. This does the trick. I moved the folder to another location, even on another partition as a test, and Terragen runs.
So you're probably right about setting the right DLL declarations valid first, from the default situation.

The reason for my specific location is related to my demand to have survey on my system.
I have more terrain-related apps, like 'Wilbur', so I prefer to have them in the same main directory as a specific 'terrain-category'.
Title: Re: No run in XP
Post by: Oshyan on August 15, 2008, 11:00:08 pm
I'm glad that addressed your needs. :)

- Oshyan