crash again

Started by Dune, December 30, 2022, 06:50:15 AM

Previous topic - Next topic


Starting out a new project I came across the same problem that has occurred before; deleting certain nodes causes a crash (TG vanishing). Here it is the simple shape, which was detached form the main line, so shouldn't be a problem. Deleting it caused a crash every time I tried (6 times in a row until I got fed up with it).
Is it because it's still visible in the viewport? Wait, I'll check that....

Strangely, I went back to my other computer and now it deletes without crashing all the time... weird.

Kevin Kipper

Hi Dune,

Which version of Terragen are you using, and which operating system?

I tried deleting the Simple Shape shader in the default Terragen 4.6.31 project, but it did not crash on my Windows 10 system.  Also tried moving that set of nodes out of the Terrain group as in your screen shot, but still couldn't recreate the crash.

Can you send use the TGD to test?


I tried on freeware, it crashed connected, but didn't crash disconnected. This has been a problem for a long time. I got by it by using a custom starting project that wasn't in TGs install.


Thanks, Kevin, but I can't anymore as I changed the file in the meantime. It was in 4.6.23, the latest alpha I have. On Win 10.

I just made a sort of similar file, but couldn't replicate it either. And like I said, the later tries didn't crash either, so it was just the first 6 sessions in a row.

I'll report back if it occurs again, and save the file then.

EDIT: just installed 4.6.31 and couldn't replicate it either.