terragen rendering slows/stops with screensaver?

Started by king_tiger_666, March 12, 2007, 05:35:36 pm

Previous topic - Next topic

king_tiger_666

Hi.. I have a render going got about 50hours, and had it going last night but this morning it has not rendered anything new still the same area was black. however once the screen saver stopped and i started checking email etc its seemed to have done a sizeable amount. like tg2 was idle for some reason. has anyone had a problem similar to this?

thanks if so this might explain why my renders taken 60hrs and the pc has been in screen saver all weekend
<a href="www.hobbies.nzaus.co.nz/">My  Terragen Downloads & Gallery</a>

old_blaggard

If your screensaver is a fancy 3D one or is otherwise resource-intensive, try turning it off.  I haven't had any problems like that myself, though.
http://www.terragen.org - A great Terragen resource with models, contests, galleries, and forums.

Oshyan

We're not aware of any such issues with screensavers in general but as o_b said if the screensaver itself uses resources and - as I believe I have seen you mention before - the priority is set to low/idle for TG2, then that would explain it. If you can do some experiments on this and let us know what you find, that would be great.

- Oshyan

king_tiger_666

i change priority when gaming, its set to normal right now and the screens saver is only the xp logo one nothing fancy.... i'll keep a eye on this and see if it happens again with other renders
<a href="www.hobbies.nzaus.co.nz/">My  Terragen Downloads & Gallery</a>

gradient

March 12, 2007, 09:59:43 pm #4 Last Edit: March 12, 2007, 10:01:33 pm by gradient
@King..... I've always turned the screen saver off....and turned off the monitor, then walk away, LOL!....50hours already...ouch, my sympathies!

king_tiger_666

March 12, 2007, 10:15:19 pm #5 Last Edit: March 13, 2007, 08:06:46 am by king_tiger_666
72hrs now... i was away all weekend so i didn't care for the first 50hrs, but its close to finished so not worth starting a new... it will be interesting to see how many micro-triangles it has compared to my 76hr clouds render... after which i told myself NO more extreme renders lol..... this is what it looks like so far...

oh well i think its worth it no less

final render can be found on this thread now  ;D ;D
http://forums.planetside.co.uk/index.php?topic=1034.0
<a href="www.hobbies.nzaus.co.nz/">My  Terragen Downloads & Gallery</a>

Oshyan

Wow, beautiful results! Aside the obvious coolness of the shaodws and rays, I really like the clouds, particularly in the upper-left. Photoreal IMO. I'd say the time is well worth it. ;)

- Oshyan

old_blaggard

Great job!  King, is there a way that you could share the model?
http://www.terragen.org - A great Terragen resource with models, contests, galleries, and forums.

joshbakr

Fantastic Scene! One of the best if not the best example of objects rendered in TGTP I've seem. And believe me I think I've seen them all.  :o  Congrats on a great work!

king_tiger_666

anyone who wants a tgo copy of the Atlantis can email me and I will forward it on

@old_blaggard email sent:D:D:D enjoy
<a href="www.hobbies.nzaus.co.nz/">My  Terragen Downloads & Gallery</a>

old_blaggard

http://www.terragen.org - A great Terragen resource with models, contests, galleries, and forums.

bigben

One thing I have noticed a few times is that as soon as you start another application (but not always) the RAM usage for TG2 will drop, in some cases dramatically. My QTVR render is typically using 0.8 - 1.1Gb but occasionally after opening another app it drops to 300Mb... even 30Mb once... and then gradually climbs back up to it's previous levels. There was no visible change in rendering speed during any of this.

old_blaggard

I've had this experience too.  My computer has 1GB of RAM, and occasionally TG2 uses up to 550MB of it - but sometimes, I'll start using an application, and some of TG2's RAM will get transferred over to the other application.  I think it's because TG2 doesn't throw away the data from a certain part of a render until there's no empty space left - afterwards, if another application needs the RAM, the OS says "TG2 isn't using this anymore... go right ahead!"
http://www.terragen.org - A great Terragen resource with models, contests, galleries, and forums.

jo

Hi,

With regard to TG2 slowing down due to a screen saver, I haven't noticed this with TG2 but I also haven't often been in a position to. I do know that on the Mac someone had a problem with the SETI screensaver kicking in and taking a lot of processor time from TG Mac v0.9 on long renders, so I added a preference to stop screensavers kicking in or the computer sleeping when it was left alone to render. Funnily enough, just the other day I was thinking about adding this to TG2. A processor intensive screensaver will definitely take time away from TG2 if it starts up.

With regard to TG2 using less RAM when you start other apps, well on OS X at least I'm guessing this is because the OS is paging out memory used by TG2 from RAM to the hard drive, to make some space in RAM for the other app. TG2 is still using the same amount of memory overall, but less of it is in RAM and more is on the HD. It does allocate some big chunks so I'm guessing during a lengthy render it might have big areas that don't get touched for quite some time, and the OS pages those out of RAM to the HD when it feels there's an opportunity, such as when a new app starts. AFAIK TG2 isn't doing anything clever with the memory, because so far it doesn't seem to much clever with memory at all :-).

Regards,

Jo