SkyBox / 360º Panorama [Tutorial] UPDATED!

Started by Floating.Point, January 22, 2011, 03:49:20 pm

Previous topic - Next topic

Floating.Point

January 22, 2011, 03:49:20 pm Last Edit: April 20, 2011, 08:13:47 am by Floating.Point


This is my (improved) method for getting seamless 360º Panoramas out of TG2.

Update:
Faster. Easier. Better!

Requirements
TG2 (with or without Animation module)
PTGui Pro (http://www.ptgui.com/)

Updated files are attached.

----------------------------------------------------------------------------

You can still grab the old tutorial below. It goes over the concepts of making cube based panoramas/skyboxes and is still good for beginners getting grips on the whole procedure. I recommend beginners to skim through the old tutorial for some info, then use the new tutorial to actually work with!

http://dl.dropbox.com/u/792881/Planetside%20Forum/SkyBoxFiles.zip

Dune


RRMessiah

I'm quite sure I set it up right, but when I hit "render sequence," it only renders 1 image. The "sequence last" value always gets reset to 1 even if I make it 6.

Floating.Point

January 25, 2011, 04:17:43 am #3 Last Edit: April 10, 2011, 01:13:36 pm by Floating.Point
(update)
check out the new tutorial attached in the first post!
you need the TG2 Animation module with the old tutorial.

Hmm not sure why that would happen.
Can you try starting a new scene and animating the default camera?
Is the problem still present?
If this is the case, perhaps its an issue with your TG2 install...
if the problem i isolated to the .tgc I provided- please let me know!
Cheers  

FrankB

Thank you. From a first look, it's done very well.

You should consider copying it to Planetside's Terragen Wiki. http://www.planetside.co.uk/wiki/index.php/Main_Page

Floating.Point

Cool, I have updated the Wiki with a link to the tutorial files!

Matt

Quote from: RRMessiah on January 24, 2011, 09:08:47 am
I'm quite sure I set it up right, but when I hit "render sequence," it only renders 1 image. The "sequence last" value always gets reset to 1 even if I make it 6.


You need Terragen 2 with Animation to render a sequence with more than 1 image.

Matt
Just because milk is white doesn't mean that clouds are made of milk.

rcallicotte

So this is Disney World.  Can we live here?

Floating.Point

UPDATE!

I have reworked this tutorial / workflow and it is much easier now... oh and much more accurate too!
(no more messing around with silly calibration renders or any of that nonsense! - stitching is now mathematically perfect, no more control points!)

See top post!

Green

whenever i do the rendering it saids finish but all i see is black

Floating.Point

April 16, 2011, 01:03:15 am #10 Last Edit: April 16, 2011, 01:43:33 am by Floating.Point
When you press render, the render window should open up and display the progress for each frame... Are you seeing this?

Have you accidentally positioned the skybox camera inside/underneath your terrain?

Are you able to render your scene without the skybox camera okay?

Green

when i press render i see the display it just stays black i can render the screen ok without the skybox camera

Floating.Point

Can you post your terragen scene, so that I can troubleshoot?

Green

April 17, 2011, 03:42:58 am #13 Last Edit: April 17, 2011, 03:50:08 am by Green
ok can do might take me a few

Floating.Point

Green,

I cannot seem to replicate your problem.

Are you using the animation version of the workflow, or the 6xStill version of the workflow?