Importing mesh into Softimage introduces Strata I don't want

Started by ajcgi, February 11, 2011, 05:57:42 am

Previous topic - Next topic

ajcgi

Hi all,
Been hovering round here for a few weeks stealthily accruing knowledge for a project I'm working on. Seems like a nice place!

I'm doing a lot of shots involving water draining out of the English Channel. For the sake of render speed and matching our background plates, I'm not using Terragen water in most shots, but using the actual footage in the background, revealed by an animated matte created in Softimage.

So I have a Heightfield Generate node at the end of my tree, run that, save as .ter and bring it into Soft. All good, the tracks match up, my colour correction mattes all line up. Great. I bring a grid into the scene to represent water level, animate that from high tide to low tide, and all seems well until I look closely. The mesh from TG2 is coming in with stepped strata so rather than moving smoothly down the land, in and out of the displaced areas of my mesh, the water level appears to jump down every few frames, then go smoothly, jump down again etc. It gives a stop motion look that totally kills the realism.

Does anyone have any clues as to what is going on or how to fix this? With TG2 water in the shots, the render times rocket.
One of the tgd files is attached.

Alex

Tangled-Universe

February 11, 2011, 06:11:12 am #1 Last Edit: February 11, 2011, 06:23:00 am by Tangled-Universe
Seems you're having "stepping" between the pixels, suggesting it's a resolution matter.

In the heightfield generate where you generate your terrain file for export you will find two parameters:
Number of points: default = 1000 = resolution of generated heightfield. I'm not sure if you can say "points = pixels".
Size in metres: default = 10000 = size of the generated heightfield

You'll need to raise the number of points or reduce the size of your heightfield. Maybe you're not using the complete 10x10km area.
You can also do both.

Please let us know if this works for you?

Cheers,
Martin

edit: I've attached a file with slightly optimized terrain size and 4 times higher number of points. Effectively ~5x higher resolution.
Examine the size and the adjust position of the initial heightfield-shader and how I translated those settings to the heightfield-generate you're using for export.

ajcgi

Hmmm that makes sense. My scenes seem to be the wrong scale which might not be helping. My current shot which should stretch to the horizon, (if i recall, that's like 2km away or similar isn't it?) stretches for about 400km. Yeah. May have an issue with that. Just doing some tests. Let's see.

ajcgi

Ok, so scale isn't quite the issue here. I'm using a painted shader to deform the mesh. It comes out lovely and smooth in Terragen, but the export ain't so great. Here's an example at the default 1000 x 1000 resolution and width settings.:


ajcgi

A close-up of what I'm getting at (plus a simple tgd):


Tangled-Universe

It's a combination of scale and number of points of course.

If you have 1000 number of points and 1x1km terrain and change that to 10x10km then you'll a much lower resolution.

Anyhow, you will need to increase the number of points a lot, but looking at the screenshot you posted that might not be the biggest problem. It will only make the steps smaller.
What you want is a smooth appearance and the reason it looks smooth in Terragen is because it applies a form of interpolation.

How do you import your exported terrain into your 3d package? Directly as .ter or as an image map? I suppose your importer would allow some form of interpolation on the data.

ajcgi

The .ter is read by a plugin we have here. The option is literally on the level of 'select file to import' so no settings whatsoever. It's more often used here to import dem data straight into Softimage I think.
Thanks for your help on this. I've had a word with the guy compositing these shots. With an fbx file containing the camera and ground plane we will hopefully be able to fake the retreating waterline in Nuke. For now we'll presume that's the route to go.
Will keep you posted.

Oshyan

I wonder if the TER reader is somehow only reading/interpreting 8-bit values or something. I don't think this is actually a pixel density issue for the export because if properly handled, even a very low resolution terrain should have adjacent heights interpolated. It will be jagged, but not *stratified* like this. This looks much more like 8 bit heightfield issues. I am also not certain that the Painted Shader wouldn't cause such issues; I have no reason other than the problem you're experiencing which would make me suspect it, but it's worth testing without it if you haven't already done so.

- Oshyan

ajcgi

Weirdly I just did another test which came in fine, but opening up any of my other TG2 scenes results in the same stepping. Think this is something I'll dedicate some time to once this project is over. Would be good to get to the bottom of it in order to help others avoid the same situation in the future. My initial thoughts are that on complete defaults settings it works fine, but somewhere along the line I've ticked a box, put in some restraint or other and thrown it off.