Ocean Artifact

Started by paross20, August 22, 2011, 02:30:38 pm

Previous topic - Next topic

paross20

Hi,

So anyone know what's causing these lines to appear on the horizon of my ocean?
I'm using Terragen 2 and tweaking the lake object to make it look like an ocean.
Also, if anyone knows the best way to get rid of/soften the hot specular hits that'd
be awesome too.


-patrick

[attachimg=#]

Henry Blewer

The lines are the seams in the object which is used to create the lake object. Try adding a power fractal to break this up.
http://flickr.com/photos/njeneb/
Forget Tuesday; It's just Monday spelled with a T

Tangled-Universe

Quote from: njeneb on August 22, 2011, 02:56:05 pm
The lines are the seams in the object which is used to create the lake object. Try adding a power fractal to break this up.


Hmmm...I never heared of this before, nor did I ever run into something like this?


Are you using multiple lightsources/sunlights?
Usually when artefacts show up in the form of lines it is because "microvertex jittering" in the renderer isn't enabled.
Perhaps you can check that?

Cheers,
Martin

paross20

Thanks for the replies. Does seem a bit odd to me, especially since i'm using a default
lake. Haven't been able to figure it out. I've tried breaking it up with a fractal as well
as trying that render setting, no luck. If anyone cares to give a crack at it I've
attached the file. Thanks again.


-patrick

Tangled-Universe

August 22, 2011, 05:35:22 pm #4 Last Edit: August 22, 2011, 05:53:39 pm by Tangled-Universe
Hi Patrick,

I have found the culprit and probably need to pass it on to Matt to see if this is worth looking at to fix.
To prevent the lines from showing up you need to access a hidden node inside the renderer.
It seemed that the adaptive subdivision algorithm causes the lines, but don't ask why exactly (see link below).

To access the hidden node do the following:
Go to your shader network and click on the "+ symbol" at the right of the rendernode.
You're now inside the internal network of the rendernode, click once on the gray background to make sure you "activate/focus" it.
Copy the code at the bottom of this message and paste it in the internal network of the rendernode. A new grey shader should show up called "render_subdiv_settings 01".
Double-click on it to see the new advanced settings. Everything is default, except that I disabled "fully adaptive".

Here's Matt on these new advanced settings:
http://forums.planetside.co.uk/index.php?topic=9321.msg128311#msg128311

Happy TG'ing dude :)

Cheers,
Martin


<terragen_clip>
   <render_subdiv_settings
      name = "Render subdiv settings 01"
      gui_use_node_pos = "1"
      gui_node_pos = "900 -80 0"
      gui_group = ""
      fully_adaptive = "0"
      force_all_edges = "0"
      jitter_shading_points = "1"
      ray_detail_multiplier = "0.25"
      stabilise_ray_detail_in_motion = "0"
      ray_detail_stabilisation = "3"
      >
   </render_subdiv_settings>
</terragen_clip>

paross20

haha, that's awesome. Thanks man, I really appreciate it. I would of had to blur it out or
something in post.  :)


-patrick



Oshyan

Actually that's a really old issue that should be fixed by enabling Microvertex Jitter in the renderer settings. Try that and see if it helps (without using Martin's instructions yet). If not, then Martin's solution could be used.

- Oshyan

Matt

Microvertex jittering was ON when it produced this artefact, so it's something else.

Good find, Martin.

Matt
Just because milk is white doesn't mean that clouds are made of milk.

Oshyan

Ah, missed the TGD that was posted, hehe.

- Oshyan