Strange banding in Clouds

Started by cyphyr, December 17, 2011, 11:22:55 am

Previous topic - Next topic

cyphyr

December 17, 2011, 11:22:55 am Last Edit: December 17, 2011, 11:33:56 am by cyphyr
Hi guys

What do you think is causing this (see pic attached) There's numerous issues with this image but it is basically how I want it.

Firstly there are unsightly concentric "bands" in the cloud layer,
Secondly there are odd haze affects in the low fog about the flanks of the island (there is NO fog layer) and,
Thirdly there are strange "blobs" in the centre back of the island.

I have no idea why these artefacts are there but it would be great to get rid of them without changing the image too much.

Higher render and quality settings do not seem to fix these issues but rather exacerbate them.

I have removed the island and models in the attached file.

Cheers

Richard

www.richardfraser.co.uk
https://www.facebook.com/RichardFraserVFX/
/|\

Ryzen 9 3900X @3.79Ghz, 64Gb (TG4 benchmark 6:20)
i7 5930K @3.5Ghz, 32Gb (TG4 benchmark 13.44)

freelancah

December 17, 2011, 12:25:27 pm #1 Last Edit: December 17, 2011, 12:32:47 pm by freelancah
Any chance you could share the clouds? Maybe easier to troubleshoot when we have more info on how the clouds are set up.. I suspect it might not be a rendering setting issue..

EDIT: oh nevermind, somehow missed the tgd file :D

freelancah

Hmm.. The problem seems to disapear when you render without the atmosphere. I recall someone having this issue and lowering haze value reduced the problem, alltho not entirely removes it. I dont have time to do further testing today but it would appear it's related to the atmosphere node

freelancah

Last test render with atmo sample jitter @ 1 seemed to reduce issues a lot

cyphyr

Hi freelancah
Yes I figured it was the atmo node but unfortunately I pretty much need those settings as they are for the "god rays".
Trying a 720x405 now and it looks promising. Atmo sample jitter is at 2 and the banding has gone as has the "fog" and "blobs"
Do you know if atmo sample jitter will have a negative effect on animation?
Cheers
Richard
www.richardfraser.co.uk
https://www.facebook.com/RichardFraserVFX/
/|\

Ryzen 9 3900X @3.79Ghz, 64Gb (TG4 benchmark 6:20)
i7 5930K @3.5Ghz, 32Gb (TG4 benchmark 13.44)

freelancah

I dont know. I imagine it might but cant say for sure

Tangled-Universe

Quote from: cyphyr on December 17, 2011, 01:30:34 pm
Hi freelancah
Yes I figured it was the atmo node but unfortunately I pretty much need those settings as they are for the "god rays".
Trying a 720x405 now and it looks promising. Atmo sample jitter is at 2 and the banding has gone as has the "fog" and "blobs"
Do you know if atmo sample jitter will have a negative effect on animation?
Cheers
Richard


I think you can't push jitter values over 1. A jitter of 0 means 0% randomization of the samples as 1 means 100%.

If you want flicker free soft shadows you would also need to set the sample jitter to 0 for the shadows.
Same goes for reducing surface flicker by disabling jitter shading points in the render subdiv nodes.

Consequently I'd expect that a sample jitter of 0 may help reducing atmo flickering.

cyphyr

Ook! stuck between a rock and a hard place as they say.
Raising the sample jitter has solved the banding issue (and the odd blobs and fog) but lowering it may help with flicker in the animation.

Quote from: Tangled-Universe
If you want flicker free soft shadows you would also need to set the sample jitter to 0 for the shadows.
Same goes for reducing surface flicker by disabling jitter shading points in the render subdiv nodes.

just to note I'm NOT using soft shadows. Do you mean the tickbox by "Micro vertex jittering" and Detail jittering" in the "Extra" tab of the render node.

One issue I'm finding is that whan it comes to subtle effects like reflection, transparency and volumetric effects they do not necessarily translate well at different resolutions. What works well at 720p is challenges at 1080p.

Thanks

Richard
www.richardfraser.co.uk
https://www.facebook.com/RichardFraserVFX/
/|\

Ryzen 9 3900X @3.79Ghz, 64Gb (TG4 benchmark 6:20)
i7 5930K @3.5Ghz, 32Gb (TG4 benchmark 13.44)

Tangled-Universe

You may need to find a trade-off setting indeed. Increased jitter may also be a tad bit slower.

I know you're not using soft shadows, but I was only explaining 2 conditions where reducing jitter improves results for animation and translated that to the issue you're having.

Oshyan

There shouldn't be flicker in the atmosphere if the sample level is high enough. I've seldom seen a useful application for reducing the sample jitter.

As for soft shadows, I don't even know that reducing sample jitter to 0 there would help in animation. I think the sample points would still vary *between frames*. The better approach, as with atmosphere, is just to use sufficient sample levels to avoid noise and thus the "flicker" (which is really noise variation between frames) won't occur.

- Oshyan

Tangled-Universe

December 18, 2011, 05:00:40 pm #10 Last Edit: December 18, 2011, 05:06:10 pm by Tangled-Universe
Quote from the 2.2.03.1 RC changelog:

Improvements to soft shadows:
- Soft shadows now use a slightly better sample distribution to slightly reduce noise.
- Sunlight has a new option "Sample jitter". Default value is 1 which qualitatively matches the old behaviour, giving jittered stratified sampling which is statistically unbiased but produces noise. A value of 0 produces no noise, but introduces bias and stepping artefacts instead. This may be favourable in some situations, e.g. animations.
- Soft shadows of Sunlight nodes no longer flicker between frames in an animation, provided that jitter is set to 0.


Quote from: Oshyan
I think the sample points would still vary *between frames*. The better approach, as with atmosphere, is just to use sufficient sample levels to avoid noise and thus the "flicker" (which is really noise variation between frames) won't occur.

- Oshyan


The jitter creates the variation between frames ;) For every frame the jitter creates a different sample pattern and that's why you need more samples, in order to have the result converge with previous/next frames. Without jittering the sampling is more evenly distributed, but can create bias/stepping as you can see in the quote above.
You are right though that with atmosphere it's better to use jittered sampling and increase samples, as reduced jitter can result in artefacts as Richard has just shown and is also in the quote above.

dandelO

Oshyan, remember the issues with the little moon shadow popping on the Saturn thing a couple of weeks ago? That's why I brought up the fact I'd neglected to lower the sample jitter in the lighting node for the .tgd, and that that would probably be part of the popping problem. I guess you missed that in one of my pm's? I'd guess that doing that would solve all the popping issues, I just assumed you'd tried it and that it hadn't fixed things.

cyphyr

Thanks for the detailed answers and analysis.
Looks like the solution will be HIGHLY scene dependant. If I want to keep the scene "exactly" the same I'll have to considerably up the sample cont. Not in front of the pc atm but I'll try upping the sample count tomorrow incrementally to a point where the banding is gone. This may help with some other issues I'm having with the scene (high noise in the reflections on the water). Hopefully this won't add too much to render times (I'll settle for twice as much!)

I'll be hopefully able to step back from the pc's long enough over the festive break to get some decent animations rendered.

cheers
Richard
www.richardfraser.co.uk
https://www.facebook.com/RichardFraserVFX/
/|\

Ryzen 9 3900X @3.79Ghz, 64Gb (TG4 benchmark 6:20)
i7 5930K @3.5Ghz, 32Gb (TG4 benchmark 13.44)

Oshyan

Quote from: dandelO on December 18, 2011, 06:00:25 pm
Oshyan, remember the issues with the little moon shadow popping on the Saturn thing a couple of weeks ago? That's why I brought up the fact I'd neglected to lower the sample jitter in the lighting node for the .tgd, and that that would probably be part of the popping problem. I guess you missed that in one of my pm's? I'd guess that doing that would solve all the popping issues, I just assumed you'd tried it and that it hadn't fixed things.


Guess I must have missed that, yeah. Oh well.

Martin, it looks like you remember the change logs better than I! Good catch. I stand corrected. I tend to forget that it's not always the sampling of the element I'm thinking of (the most "obvious" element to me in a given situation) that matters. In this case it's the light being sampled (which is obvious from the jitter control of course - I should have drawn the right conclusion from that fact alone), not the terrain sampling (which does change frame to frame), that matters, and that stays the same (dependent on the jitter setting) regardless of camera movement (unless light settings change between frames of course).

- Oshyan

cyphyr

Erm, well I'm now confused! (not difficult I know)
The scene has rolling clouds so I guess that means the light will differ between frames.
The sample quality of the clouds has to be high to avoid noise about the edges of the cast light beams.
The atmosphere sample quality also has to be high to show the light beams without noise.
So basically there are no "clever cheats" to get around long render times, I'll simply have to raise the detail and sample quality to a point where both the banding and noise disappear and live with the extended render times. Oh well its my own fault (as usual) for going for a scene with so many extremes! lol
Cheers again
Richard
www.richardfraser.co.uk
https://www.facebook.com/RichardFraserVFX/
/|\

Ryzen 9 3900X @3.79Ghz, 64Gb (TG4 benchmark 6:20)
i7 5930K @3.5Ghz, 32Gb (TG4 benchmark 13.44)