64bit win7 sky incomplete...cause?

Started by Dune, March 02, 2012, 03:52:47 am

Previous topic - Next topic

Dune

I get this strange view on my i7 (win 7 pro, 64 bit). It is an alpha version, but that probably won't make a difference. I wonder why the sky doesn't show properly in the 3D preview. Is it the graphics driver or TG? Any ideas?

Dune

Martin's idea to update drivers did the trick. Topic closed. Thanks, Martin!

Dune

Unlocked it again, as I found that the updated (Intel_Graphics_V815102405_VistaWin7) graphic drivers messed up TG. I got crashes all the time when adding an object or opening a tgd with objects and setting display to wireframe. It seems the new drivers can't handle the wireframe somehow, or vise versa.

I had to get back to the old state to be able to work with TG  >:( ??? :(

Tangled-Universe

I think this is useful to know for Jo/Matt that there are issues when someone like you uses an IGP based GPU instead of a 'regular' graphics card.
Basically you're not updating a catalyst driver for ATi or Nvidia drivers, but updated motherboard drivers for your Asus P8Z68-V with an i7-2600k.

freelancah

Have you tried changing the clipping planes?

jo

Hi,

When I have seen this it's normally fixed by either updating or reverting drivers. Sometimes a new driver causes problems, sometimes it's ok. IIRC sometimes a restart helps. Generally speaking, it's a driver problem.

Regards,

Jo

jo

Just to add that yes it could be the 3D Preview clipping planes but if you've just changed your drivers that's likely to be issue. Clipping plane issues can normally be fixed by clicking the Reset button in the 3D Preview.

freelancah

My server used to do that with old drivers and the clipping plane was never right by default. The update helped but I have no idea why it would do something like that

Dune

Excuse me my ignorance, but what's a clipping plane? As I only use that i7 for TG renderings, without actually working in them, it's not that awful to not see the sky. But it's still annoying that updates degrade some things. Would resetting the 3D preview help and only be necessary once, or do I continually have to deal with that problem if I decide to update again.
If it would help to insert a proper video card, that's what I would consider.

freelancah

March 04, 2012, 12:06:41 pm #9 Last Edit: March 04, 2012, 12:20:03 pm by freelancah
Clipping planes are essentially the area that the opengl renderer renders. See attached image. You can adjust it from the bracket keys [ and ] or depending on your setup.. On my scandi keyboard it's å and ´

I'm fairly sure this is a clipping plane issue because it's exactly like mine was. I dont recall if I did anything else than change drivers to fix it since it was over a year ago..

Dune

I may sound dumb, but if I update the drivers again and hit the bracket keys to reset the clipping plane, it should work for all times (TG remembers?)? Or do I have to hit the bracket keys every time I open TG?

jo

Hi Ulco,

No, TG2 doesn't remember the clipping plane settings. You would have to change it every time. I don't know if the sky issues are a problem peculiar to the Intel GPU.

Clipping planes control the precision of the depth values in the 3D Preview i.e. distances from the camera. It may be that the Intel GPU doesn't have high enough precision to handle the scene, but I don't think that's too likely. I really don't know though. I would still suspect the drivers over anything else.

Regards,

Jo

Dune

Thanks, Jo. Then I'll stick to the old drivers. I don't like crashes  ;)