Freezing colour menue works again?

Started by Mahnmut, June 17, 2012, 05:08:11 am

Previous topic - Next topic

Mahnmut

June 17, 2012, 05:08:11 am Last Edit: September 14, 2012, 02:36:08 pm by Mahnmut
Hello there.
I got a problem that makes it impossible do get anywhere with terragen:
As soon as I try to open a colour-selecting-menue (no matter if its a clouds colour, a layer or whatever) terragen freezes and doesn´t come back.
I got an i7 with an inbuilt nvidia graphiccard and windows xp  7 64.
Any Ideas?
Best regards, Jan

Oshyan

Have you verified that you have the latest graphics drivers? If so, can you try turning down Hardware Acceleration in your graphics driver? These steps should work:

1. Choose Start > Control Panel.
2. Double click Personalization and select Display Settings.
3. Click Advanced Settings.
4. Click Change Settings on the Troubleshooting tab.
5. Move the Hardware Acceleration slider to None.
6. Click Apply and then click OK to accept the new setting and close the dialog box.
7. Click OK to close the Display Properties dialog box.
8. Restart Windows.

- Oshyan

Mahnmut

Thanks for the quick answer.
trying to follow your advice I realize that it´s windows 7 I am using. I don´t know if that makes a big difference, but I can´t find any hardware-acceleration  options. Maybe I should emphasize that only Terragen freezes, I can still open other applications in the meantime, but I have to shut TG with the taskmanager. Sorry for the confusion!

Oshyan

Win7 should still have the hardware acceleration options. The steps I posted were for Win7 in fact. Since you can't find that setting, did you verify that you have the latest graphics drivers? Can you provide a more specific model number for the graphics card you have? You can also try switching to the "Classic" theme and/or turning off Aero if it's enabled.

- Oshyan

Mahnmut

I thought first of all I should actualise my graphics driver, as mine is from 2010.
But I can´t. Windows tells me I gotthe newestdrivers and the instalation stops.
My graphics card is a "NVIDIA GeForce 310M", driver version says "8.16.11.8999".
Thats all I know, I downloaded the newest driver file from the Nvidia homepage, but it doesn´t work. (probably because I don´t know how to).
By the way, I switched of the hardware acceleration (had to download a program for that) and that doesn´t solve the problem.

Best Regards,
Jan

jo

Hi Jan,

Here's something you could try:

- Choose "Reveal Key File" from the Help menu.
- In the folder which opens there might be a file called "customPickerColours.dat". If there is delete it.
- Quit TG2 and then start it again.
- Try to open the colour picker.

That might solve your problem, it worked for someone else with a similar sounding problem to yours. Please let me know if it works.

Regards,

Jo

Mahnmut

Thanks Jo,
but is that option available in the free version?
I am pondering buying the full version, but not before I know it runs on my laptop.
Best regards,
Jan

Oshyan

The Reveal Key File option won't be there in the free version I suppose, but you can just navigate to the data directory for TG2 (or do a file search on your computer for "customPickerColours.dat". On my system it is found in: C:\Users\USERNAME\AppData\Roaming\Planetside Software\Terragen 2

- Oshyan

Mahnmut

Thanks Oshyan for the detailed advice!
I found the file and deleted it, sadly that didn´t help.

Mahnmut

Ok, now I got the full version,
I´ll have fun for some time rendering old projects big, but sooner or later I´ll need a new colour.
My laptop insists on having the newest drivers, I even deinstalled the old ones in order to "persuade" it, but some kind of auto repair reinstalled them.
Any idea how to actualize Grafics drivers on a dell vostro 3300?
Or any other ideas on how to get my colour menues working?
Best regards,
J

Kadri

September 14, 2012, 12:27:35 am #10 Last Edit: September 14, 2012, 12:40:59 am by Kadri
You probably searched for this problem Mahnmut.
I found this for example:

http://www.dell.com/support/drivers/us/en/19/Product/vostro-3300

When you change the Operating system on the top to Windows 7 64 (if this is your operating system )
and then look to the Video part at the bottom you will see 4 drivers to choose from.
I don't know how much you know in general or about your hardware but maybe you did not choose the right driver.
First be sure what graphics hardware you have and then try to install the right driver from here.

But make a system restore point before anything and be cautious.

It looks that your laptop have 2 graphics card. Try to switching to the other one if possible Mahnmut.
Look here too if you are not familiar with these kind of things.

http://support.dell.com/support/topics/global.aspx/support/kcs/document?&docid=DSN_324722&isLegacy=true
Edit: http://www.sevenforums.com/graphic-cards/138403-need-detailed-help-about-nvidia-geforce-310m.html
There could be better pages too of course.
Hope this helps!

Mahnmut

Thanks for the advice kadri, I may try that some time.
Well, I wouldn´t say the problem is solved, but it´s gone for now.
I didn´t change anything, just hit a colour button out of habit (the way that so often made me curse in the last months because TG froze in the middle of the flow.)
And there it was, a colour menue I hadn´t even seen before, I love the way it offers you variants!
I hope it stays like that, I have been changing colours for half an hour now and everything is fine!
Best Regards,
J

Oshyan

Glad to hear the problem seems to be resolved for now. Hope it stays that way!

- Oshyan