Obj Importer not reading Transparency

Started by DannyG, July 22, 2012, 12:32:59 pm

Previous topic - Next topic

DannyG

July 22, 2012, 12:32:59 pm Last Edit: July 22, 2012, 12:36:16 pm by DannyGordon
Below are some issues I am having with X-Frogs objs imported into Terragen, I initially thought it was a mapping problem with the models, however a response from X-Frogs was TG is not assigning transparency correctly. I attempted several different settings within the plants internal node with no success. Hope its something easy. Any help would be appreciated as this is affecting dozens of my X-Frogs plants


New World Digital Art
www.NwdaGroup.com
Media: facebook|Twitter|Instagram

Tangled-Universe

That indeed seems like a transparency issue. To be exact I think the transparency image needs to be inverted (black leaf and white edges from white leaf and black edges).

Have you been able to isolate which texture is causing the problems?
Usually there's a shader for stem, petal, leaf etc. So which one has the error?

If you have isolated it then open the shader and first you'll see the diffuse colour texture.
If it is a .tif file (XFrog models usually come with .tif texture files which have an alpha channel for transparency) then you probably should see the same texture appear in the opacity tab. If so, then check "use transparency from alpha" (or something along that line, doing this by heart now).

If it is a .jpg/bmp or .tif without alpha channel then open the texture in an image editor like Photoshop and prepare the transparency image yourself.
You can do this by making the leaf completely white and the surroundings black. Select the white area and shrink it by 1 pixel or 2 extra to make sure that no white goes beyond the leaf's edge.

Another option is to open the .tif from XFrog in an image editor and save the alpha channel as a separate .bmp/jpg and load that separately into the opacity channel of the shader.

DannyG

Thks TU, it turned out to be happening with the same models in Mojo, daz and Terragen, Opacity was not mapped in the pedal nodes. A bit annoying but fixable
New World Digital Art
www.NwdaGroup.com
Media: facebook|Twitter|Instagram