color picker doubles up. Bug?

Started by lat 64, September 05, 2012, 07:09:56 pm

Previous topic - Next topic

lat 64

Does anyone else get two color pickers, one after the other, in TG2?
I do every time I select a color swatch to edit color. I usually just kill it like a mosquito and go back to work, no biggie.
Is this a personal problem with me or a bug?

I'm on a Mac, OSX Ver. 10.5.8;
Terragen V2.4.32.1 64-bit

Russ
I'm a half century plus ten yrs old. Yikes!

jo

Hi Russ,

I don't think I've ever seen that. I tried it on 10.5.8 and it worked as expected.

Just to be clear, does this happen when clicking a colour button in a node parameter view?
Do you get two TG2 colour pickers? I'm presuming you know what the Apple one is like.

The only thing I can think to suggest is trashing your TG2 preferences. In fact perhaps trashing them is a bit strong considering I'm not sure if it will help. It might be best to rename them, restart TG2 and see if it helps and if it does then trash the old prefs. You can find the preferences in:

Your user folder -> Library -> Preferences -> uk.co.planetside.Terragen_2.plist

Rename the file to something like "uk.co.planetside.Terragen_2.plist_old". If you restart TG2 and it works properly then throw that file away. If you still get the double picker then trash any new preferences file created and remove the "_old" from the old preferences file.

BTW, I'm not sure if I mentioned this to you before but TG2 renders quite a bit faster on OS X 10.6 if you have a multicore machine. I definitely recommend people upgrade to 10.6 if possible.

Regards,

Jo

lat 64

September 06, 2012, 01:38:19 pm #2 Last Edit: September 06, 2012, 02:53:44 pm by lat 64
Hi jo,
Thanks for the response.

<Just to be clear, does this happen when clicking a colour button in a node parameter view?>

Yes.

<Do you get two TG2 colour pickers? I'm presuming you know what the Apple one is like.>

Yes, two TG2 pickers. I can also bring up the apple picker(ha) if I want by clicking on the little palette icon.

It is very consistent. I always get a second TG2 color picker after I close the first. Either by the "OK" radio button or the "Cancel" button.

I made a new preferences list like you said. No changes.

This is not a hold up for work progress, just a weird little thing that I thought might be bugging others. If I'm the only one, then I may do a reinstall or something.
I will definitely look into OSX 10.6.

Thanks again,

Russ
I'm a half century plus ten yrs old. Yikes!