Using smooth normal for objects

Started by Aerometrex, September 17, 2012, 02:51:27 am

Previous topic - Next topic

Aerometrex

September 17, 2012, 02:51:27 am Last Edit: September 17, 2012, 02:56:41 am by Aerometrex
Hi all,

I've noticed that objects saved through Meshlab can be smoothed using the option "smooth normal" but those saved using Blender cannot.
It looks like the internal structure of the .obj file play a big part.

Exemple of blender obj:

# Blender v2.63 (sub 0) OBJ File: ''
# www.blender.org
mtllib Tile_+003_+005_b.mtl
o Mesh_Tile_+003_+005
v 314.920868 225.121323 59.314941
v 314.813904 225.432617 58.864132
v 314.722443 225.320709 59.094215
...
vt 0.410758 0.195222
vt 0.409403 0.195584
vt 0.409994 0.194806
...
vn 0.264288 0.821804 0.504767
vn 0.552854 -0.833044 0.019757
vn 0.147174 0.981295 0.124093
...
usemtl Texture_0_Tile_+003_+005_0.jpg
s off
f 1/1/1 2/2/1 3/3/1
f 4/4/2 5/5/2 6/6/2
f 7/7/3 8/8/3 9/9/3
...

Meshlab
####
#
# OBJ File Generated by Meshlab
#
####
# Object Tile_+003_+005_n.obj
#
# Vertices: 88887
# Faces: 175069
#
####
mtllib ./Tile_+003_+005_n.obj.mtl

vn 0.146510 0.685405 0.713270
v 314.920868 225.121338 59.314903 0.752941 0.752941 0.752941
vn -0.019928 0.749740 0.661433
v 314.813904 225.432632 58.864094 0.752941 0.752941 0.752941
vn -0.390792 0.732805 0.557026
v 314.722443 225.320724 59.094177 0.752941 0.752941 0.752941

usemtl material_0
vt 0.410758 0.195222
vt 0.409403 0.195584
vt 0.409994 0.194806
f 1/1/1 2/2/2 3/3/3
vt 0.817537 0.912835
vt 0.818565 0.913163
vt 0.817691 0.915279
f 4/4/4 5/5/5 6/6/6

I'm now using Meshlab to save all my objects before importing them in Terragen if I need to have smooth objects.

I am passionate  about the art and science of digital aerial mapping, photogrammetry, geospatial information, VR and 3D modelling.
http://aero3dpro.com

Upon Infinity

3D Models / Art Prints: www.uponinfinity.com | YouTube | Twitter | Support My Work

masonspappy

I may be confused (happens quite often) but, is the attached image what you are referring to?  The UV sphere was  saved exported twice from Blender, first time unsmoothed, second time smoothed.
- Cam

Klas

you can enable smoothing in blender or edit the .obj and change "s off" to "s on". Or use poseray.