Clouds loaded from clip file render as if they were on default planet

Started by TheBlackHole, December 22, 2012, 12:52:11 am

Previous topic - Next topic

TheBlackHole

I have a set of 5 cloud layers I loaded from a clip file that I'd made a while ago. The planet I want them on isn't in the same place as the default planet (which I deleted) and the clouds render in the same place they would if loaded into a default scene. How do I fix this again?
They just issued a tornado warning and said to stay away from windows. Does that mean I can't use my computer?

Oshyan

Disconnect then reconnect the Atmosphere node. It needs to be connected directly to the planet to re-set the coordinates, after which you can put it back at the top of the cloud/atmosphere network.

- Oshyan

TheBlackHole

Didn't work. The planet's atmosphere is rendering fine; it's just the clouds that are in the wrong place.
They just issued a tornado warning and said to stay away from windows. Does that mean I can't use my computer?

Oshyan

How are your clouds connected in to the node network? Is it Atmosphere feeding into clouds feeding into planet?

- Oshyan

TheBlackHole

Yeah, it's atmo>cloud 1>cloud 2>cloud 3>cloud 4>cloud 5>planet 02. There is a planet "Planet 01" but it's being used for a glow effect around the sun. When I made the clipfile, the planet the clouds were on was also "Planet 01"; maybe that could have something to do with it?
They just issued a tornado warning and said to stay away from windows. Does that mean I can't use my computer?

Oshyan

It should be able to reset when you connect atmo directly to the planet, then back where it was (through the cloud layers).

- Oshyan

TheBlackHole

I tried that a million times and the clouds still didn't render on the planet.
They just issued a tornado warning and said to stay away from windows. Does that mean I can't use my computer?

Oshyan

Which planet are you trying to get the clouds to work on?

- Oshyan

TheBlackHole

They just issued a tornado warning and said to stay away from windows. Does that mean I can't use my computer?

Oshyan

Very strange indeed, I can't fix it either. I wonder if it has something to do with your use of the "rotation", "heading" and "distance" parameters. Having never been able to predict where those will move my planet to, I've never really seen the point and don't use them, I just drag the planet. Perhaps some combination of those parameters and regular translation/movement has messed things up. I'm opening an issue in our internal tracker with the file attached, hopefully Matt or Jo can make something of it.

- Oshyan

Kadri


I did some tests and it crashed TG2 on Windows 8 64 bit.
So i did not go much further and i do not know what you want to try-are after TheBlackhole.

But changing the distance settings to lower then 006 produced some different renders
together with turning on and off and changing Atmo+cloud orders in the node chain.

Changing the distance to 006 in the end changed the appearance too ones more.

We had a thread with DandelO in the past about it.
Using the numbers is problematic in the Planet settings.
The safest way is to drag the Planets.

Not sure if this is what you are after TheBlackhole.

TheBlackHole

This is what I'm going for, but with clouds on the planet.
They just issued a tornado warning and said to stay away from windows. Does that mean I can't use my computer?

Kadri


When i edited the TGD file manually (the "center" of the clouds) i got this.
Take a look of yourself i made it hastily.
Hope this helps somewhat.


But it is strange why TG2 doesn't update it as in my problem and the way Oshyan said too.

[attachurl=2]


[attachimg=1]

TheBlackHole

They just issued a tornado warning and said to stay away from windows. Does that mean I can't use my computer?

Kadri


:)


I looked ones more at the file and it is actually very easy to change.
You have more then one cloud layer node TheBlackHole .
Changing the input of only the last one on the node chain doesn't work (it works probably but the others are hiding it maybe).
You have to manually change the inputs of all the nodes one by one.