Object Shadows...

Started by choronr, May 20, 2007, 03:41:11 pm

Previous topic - Next topic

Buzzzzz

I'll put a bug in his ear and try and get him back here. Probably not today though, you know the Family Cookout thing.  ;D

Thanks Oshyan,
Jay

Oshyan

Sounds good. I hope to do some BBQ'ing today myself. :)

I'm messing with the file right now but without the terrain it's a bit iffy whether my results are going to be at all comparable to his.

- Oshyan

Oshyan

The problem was that "Do Ray Traced Shadows" was unchecked in the renderer under the More Settings tab. This is absolutely necessary to get shadows of any kind. Note that this is different than the Ray Traced Shadows in the Atmosphere and Cloud Quality tabs which control certain shadow characteristics particular to the clouds and atmosphere. Normally these can both remain unchecked and enabling them greatly increases render time. In the case of the similar option in the main renderer you are actually disabling *all* shadows.

The cloud samples for the 2D layer and the number of atmosphere samples are also quite excessive for this scene. These high settings should not be necessary and likely only increase render time without any render quality improvement. It's important to understand the impact of the various quality settings and to experiment in each given scene with crop renders to ensure the best mix of detail settings so you get a high quality render in a reasonable time frame.

- Oshyan

choronr

Thanks Oshyan for your response. I am in the process of building a new PC; and, as soon as all is up and running properly, I will post the 'Navajo Point' terrain on my web site for download. I'll let you know when this is done.

Also, thanks for the tip regarding the ray traced setting on the renderer. I'll do a quick, cropped render to see if this works. Someone had left a comment that the trees are actually above the ground - maybe this is why there are no shadows!

BTW; I have decided to not to load the 64 bit version of Vista Ultimate on my new PC. I may be being over careful; but, I need to be sure that all my programs work - especially Terragen 2!

   Bob (I'll get back to you)

choronr

Oshyan; I checked the ray traced shadows in the renderer and made a small, cropped render - but, still no shadows. One other thing that is noticeable is that the 'sun side' of the trees are not brighter as they should be ...another thing that is amiss here.

I'll get back to you after I upload the DEM terrain on my site for download. This may not be until later in the week.

   Bob

Oshyan

In the .tgd you provided the disabled ray traced shadows made everything look very flat, as you describe, with the sun-side of the tree not being lighter. Enabling ray traced shadows fixed that immediately on my end. I am really confused as to why it doesn't seem to do the same on your end. Providing rendered image examples of the results you're seeing would be tremendously helpful in further diagnoses.

- Oshyan

choronr

Thanks Oshyan; I will render a 640 x 480; or, a cropped area of a 1280 x 960 to show the result. Will be back to you with the results as quickly as it will render on my old machine.

Again, thank you very much for your help.

   Bob

choronr

Oshyan; here is a cropped render of the scene wherein the trees are not producing shadows. I note a great improvement since I activated the ray traced shadows in the renderer; however, the tree shadows are still a problem. Also, I think that maybe the 'fill lights' are too strong since it appears that I have a sand (or snow) layer on the horizontal surfaces.

Attached are a .jpg of the cropped scene; and, the latest updated .tgd file.

Thanks for your help.

   Bob

Oshyan

OK, given that this continues to occur I think it's important for me to have access to all the files involved here to exactly reproduce your problem scene. I will be needing the terrain at a minimum, and potentially all the texture files as well, if possible. I can provide upload space or you can email the files directly to support@planetside.co.uk

I don't think this is the result of a bug as it's not something we've seen anything similar to before as a known issue and objects have been tested fairly extensively. But you never know, and we'd certainly liek to help you get this working regardless.

- Oshyan

choronr

Thank you very much Oshyan, I will work on getting all the files to you later today. The terrain file is 32MB; so, I'll have to get in on my web site so you can download it. I'll get back to you with a message letting you know that it is ready for download. I'll e-mail the other texture files to you as you suggested ...your response here is appreciated.

   Bob

Oshyan

Hi Bob,

I have taken another look at your scene now that I have a moment and I've found several other problems and unusual configuration options.

First, you do have your objects offset from the terrain in the population by specifying a non-0 number in the middle coordinate for "Area centre". This is the Y or vertical axis. This means your objects aren't sitting properly on the terrain.

Second, and perhaps most important to the shadow problem, your fill lights are at a fairly high strength. Their combined brightness is going to wash out most shadow you would see, especially with your low sun angle and the distance of your camera.

Finally you are specifying a *luminosity* texture and strength for your leaf textures in the tree object. This is going to give you a luminous tree - i.e. one that provides its own light to the scene - and this is no doubt resulting in the odd unshadowed look you're seeing in the trees themselves (regardless of shadows on the ground).

I think these issues account for the effects you're seeing and so I would say this is expected behavior given your settings. In the future if you're having problems with populations or any other particular feature I can't stress enough the value of trying it in a *default* configuration before experimenting further. That way you know that it's probably not the setting adjustments you've made that is causing any problems you see.

So in summary, to fix your scene I would recommend doing *all* of the following:

Turn on Ray Traced Shadows in the renderer's More Settings tab
Set Y axis position value for populator(s) to 0
Reduce fill light strength to 0.2-3 or less for all fill lights
Remove Luminosity texture from leaves entirely and set luminosity value to 0

- Oshyan

choronr

Oshyan, I really appreciate your time scrutenizing this file. I will cover all the issues and make adjustments. The think I once tried the 'zero' for the 'Y' dimension but it didn't work - however, this was some time ago and I've made many other adjustments since. Jay tells me he has been using 512 DEM files he downloaded from 'Timster's' site with great success. Although the terrain sizes he has used is only 512, Terragen 2 seems to bring out excellent details - especially when using a bit of displacement.

I will get back to you with the results of the adjustments I've made.

One more question: When one uses fill lights, are the settings of these lights set at default numbers; or, do they adjust automatically based on one's sun settings?

Thank you Oshyan for helping me out.

   Bob


Oshyan

Fill lights are independent of the sun and of each other and must currently be adjusted manually to match other lighting settings. In general you may find that leaving them at the defaults or setting them to a good level and then using the camera exposure settings will yield a better, more even adjustment of brightness for different times of day without having to fiddle with strength for 3 different lights.

- Oshyan

choronr

Thanks Oshyan, this will be helpful.

   Bob

choronr

Hi Oshyan,

I adjusted the following based on your suggestions:

Turn on Ray Traced Shadows in the renderer's More Settings tab This worked well including shadows from the fake stones and terrain.
Set Y axis position value for populator(s) to 0 This did not work; both, for the trees and the grass clumps. Still, there are no shadows.
Reduce fill light strength to 0.2-3 or less for all fill lights The effect of fill lights were greatly improved with a setting of .175.
Remove Luminosity texture from leaves entirely and set luminosity value to 0 This did show improvement although the colors must be lightened.

I think I'm beating a dead horse. It seems there are other elements causing this 'shadowless tree/grass clump' problem.

   Bob