Author Topic: 3D preview issue on close-up  (Read 1210 times)

Offline otakar

  • Member
  • *
  • Posts: 1233
  • Procrastinate later.
3D preview issue on close-up
« on: February 27, 2013, 10:08:00 PM »
TG 2.5.4.0 64-bit Win7

Please refer to the attached screen shot. I get an area in the 3D Preview pane that does not get rendered when I move the camera close to the terrain. Here the camera is .6m above ground. As you can see the actual render works fine (Quick or full render, does not matter).

It's driving me nuts, I can't see any setting that I've changed. I just opened up a new project, added a layer masked by a simple shape shader. If I pull the camera higher the area that fails to be rendered on the preview gets smaller until it disappears (when I move the camera to 1.1 m above ground).

Any clues?

Offline yossam

  • Member
  • *
  • Posts: 3072
Re: 3D preview issue on close-up
« Reply #1 on: February 27, 2013, 10:20:11 PM »
On your keyboard, on the righthand side. Push the bracket symbol ([). You might have to push it a couple of times. It will not stay, you will have to do it again every time you change pages.

Offline Oshyan

  • Planetside Staff
  • *
  • Posts: 13116
  • Holy snagging ducks!
Re: 3D preview issue on close-up
« Reply #2 on: February 27, 2013, 10:37:09 PM »
This is due to how close you are to the terrain. The setting Yossam suggests changing is adjusting the clipping plane.

Terragen works with incredibly large scales and there is a limit to the total number of values that can be represented by typical graphics hardware, so you can either have very large distances with poor accuracy, smaller distances with great accuracy, or some kind of curve, with greater accuracy in the foreground. Even still, there are limits, and so clipping planes describe the closest and furthest distances that will be represented by the system, beyond which they are "clipped", and thus don't have to take up space in the coordinate system, essentially. Moving the clipping plane lets you adjust the bias, near or far, for the numerical range being represented. It is set by default at a range that works for most scenes, but as you have seen in this case, it does sometimes need to be adjusted. It is fortunately a rarity, however, which is why it's not a permanent setting.

- Oshyan

Offline otakar

  • Member
  • *
  • Posts: 1233
  • Procrastinate later.
Re: 3D preview issue on close-up
« Reply #3 on: February 28, 2013, 03:55:42 AM »
Thanks for the quick replies! I can't believe I have not come across this one yet, I did a search for "clipping plane" and saw a good number of threads about this. Will report back when I have a chance to try the solution!

Offline otakar

  • Member
  • *
  • Posts: 1233
  • Procrastinate later.
Re: 3D preview issue on close-up
« Reply #4 on: February 28, 2013, 05:23:23 PM »
Yep, hitting that "[" key worked just fine. Thanks again!

 

anything