Visibility issues with painting a shader

Started by SteveR, August 26, 2013, 10:20:04 am

Previous topic - Next topic

SteveR

Hi all, it's the first time I've been using this function so this may be a daft question with an obvious answer...

I am working on a scene and need to paint a user shader that I will use to drive a mask for a distribution shader. My issue is that when I select "Start Painting User Shader" my nice clear openGL preview seems to get a overlay which serves only to reduce the contrast of my 3d view making it very difficult to paint around the terrain.

Example 1 below is my normal preview, and the other image is what happens when I start painting the shader. I do not understand why I am getting this overcast layer so to speak - just makes things hard to see.

[attach=1]
[attach=2]

As an aside, is there a easy way to switch between draw na erase when painting your own shaders?

Many thanks
Steve

P.S. I am on TG3Pro.

Kevin F

That's the normal way things are. It's so that you can still see the original and see your painted area as an overlay. To switch between paint and erase just go back to the "start or stop painted shader  paint session" and a new option of "paint or erase" appears.

jo

Hi,

Kevin has answered your questions. However I should add I thought there was a shortcut for changing between paint and erase strokes and then found there wasn't, so I'm going to add one :-).

There is a guide for the Painted shader here:

http://www.planetside.co.uk/wiki/index.php?title=Painted_Shader_Guide

Regards,

Jo

SteveR

Thanks Kevin, I hear what you are saying, but the complete overlay (not just the bit you have masked) makes it a lot harder to see - when it could be 100% transparent - ie you only see what you have painted - the background in the preview does not get reduced in clarity.

Thanks for the info about the paint/erase Jo,  I was looking for a keyboard shortcut - so glad TG is going to get one - be handy :)

Thanks
Steve