No GI below equator

Started by bigben, July 03, 2007, 11:07:58 pm

Previous topic - Next topic

bigben

Did a quick search and didn't find anything...

I turned on GI for a planet render to fill in the shadows on a model. The partial render is below, with a completed render without GI. The area south of the equator is identical to the image without GI.

Detail 2, AA 3, GI 3,4

Bump map, surface texture and cloud blending shader all spherical projected images.

Oshyan

Are you using any coverage adjust in your cloud nodes?

- Oshyan

old_blaggard

Awesome render and perspective, by the way.
http://www.terragen.org - A great Terragen resource with models, contests, galleries, and forums.

bigben

There is one positive and two negative coverage adjustments in the clouds nodes (forgot to remove the positive one). Their density fractals all have positive coverage adjustments.

bigben

It does seem to be cloud related.

  • Set all coverage settings (cloud and fractal) to 0: still there

  • Disabled all clouds: not there (but not much difference to no GI render, so it may be that it's just not noticeable)

  • Disabled existing clouds + default cirrus layer: still there


Oshyan

I have seen similar problems before when using coverage adjustment specifically in a cloud layer. Would it be possible to provide the .tgd for further investigation? You can email it to me privately if you prefer.

- Oshyan

bigben

Already attached to the first post ;)

Certainly no secrets in there.

Texture maps are from here:
http://www.oera.net/How2/TextureMaps2.htm

bigben

Following in tandem with RArcher's problem... here's a cropped render with GI on and the reflecivity shader removed. The distribution of GI has increased a bit and you can clearly see that it's not a straight line.

I'd added a weak fill light as well but I don't think it made the difference.

bigben

Still guessing....

One thing I noted was that the camera position has a large negative Y value.  I set it to 0 and it seems to be working although of course this gives a completely different view. I'm running a 10 frame animation between the two positions to see if it's possibly related to this.

Oshyan

Thanks for the continued investigation. I'll try to get a chance to look at you and Ryan's files this weekend.

- Oshyan

bigben

July 07, 2007, 08:07:50 pm #10 Last Edit: July 15, 2007, 07:03:45 pm by bigben
Made some progress, but not what I expected.

The first frame displayed the error even though the previous render of the same camera position didn't.  The only difference between the two was the detail level (it takes a while to render) so I stopped the sequence and tried some different detail settings.  At 0.5 it doesn't appear from this camera angle... it's there at 0.75, and spreads further with detail at 1.0. Added another image with render detail 2.0 showing that the area without GI has spread.

bigben

Just giving it a nudge, with the last image added

Matt

Hi Ben,

Thanks for the new information. I will look into this problem soon.

Matt
Just because milk is white doesn't mean that clouds are made of milk.

Oshyan

I'm currently hacking on RAarcher's file and will check this one out when I'm through with it. ;D

- Oshyan

bigben

No hurry...  I was just wondering if there was anything else you wanted me to try rather than you having to check through everything.  It may just be coincidence but there did seem to be some sort of link between the two problems.  If you find a workaround for RArcher's problem let me know and I'll test it on mine.