Terragen stops working - mainly when populating

Started by Simon_, June 12, 2014, 07:50:40 AM

Previous topic - Next topic


Hi - I've just downloaded TG3; it looks great and will do great things - but have hit a very frustrating error.

I get a "Terragen 3 (64 bit) has stopped working"  error nearly every time I try to populate a scene (and at other times more randomly - haven't worked out any other patterns).

I click on objects > add object > population > tgo (or .obj) reader  (browse for the model) click populate

I've tried importing simple .obj shapes (cube) these fail (as a population) as well as a 1.5mb (xfrog .tgo tree)

I've tried deleting the library contents, reinstalling, and the 32 bit version.

It worked after that once when I had also reduced the area of the population and I had 5-6 objects displayed (the tree usually imports and renders singly), but the next time I tried it it failed.

I have a laptop 4RAM, processor 2.5ghz.
Windows 7, 64 bit.
I'm not sure about the graphics card: under Display Adaptors in the Device manager it says Intel(R) HD Graphics.

Anything else I can try? Any help much appreciated.




As far as your settings in the populator are concerned I can see nothing wrong.

Did you load Red Cedar object into the library somehow? I did not use the library yet but just added my objects from directories on my hard drive, as you normally do. Perhaps you should do just the same. I made several tests in TG3 trial version and did not get any errors. Did not use the library either...

Also, graphic card amounts for little. It is not the source of the problem if you ask me.
"This year - a factory of semiconductors. Next year - a factory of whole conductors!"


Do you see a lot of hard drive activity before it stops responding?  Maybe maxing out memory.
(04Dec20) Ryzen 1800x, 970 EVO 1TB M.2 SSD, Corsair Vengeance 64GB DDR4 3200 Mem,  EVGA GeForce GTX 1080 Ti FTW3 Graphics 457.51 (04Dec20), Win 10 Pro x64, Terragen Pro 4.5.43 Frontier, BenchMark 0:10:02


Hi - the tree model didn't go into the library (the sphere model I tried did somehow end up in the library though and I had difficulty deleting that - clicking on the library froze everything for a while).

Good to know that card unlikely to be the problem.

I will check what happens to memory with the task manager. I'm currently testing on an old desktop PC at home (the laptop is a works machine) and while it is very slow and the memory use at 100% - it plods on with the render nicely (rendering lots of trees - like the set up in the preview screenshot).

It would be good to get it working on the laptop as it is much faster.

Is there an easy'ish way of allocating more more system resources to TG?

Thanks for your thoughts and ideas on this - very helpful. I will do some more testing.

I forgot to mention that I tried - clutching at straws - compatibility mode (for vista) and running as administrator.




Hi, Simon.
Try populating, but before you do, close the 3D Preview window completely(top-right). Or, you could also run Terragen with no 3D preview from the program folder.
The preview window uses your graphics card(and it sounds as if you don't have one as you mention the Intel listing in your device manager), I had problems before with TG app' terminations on populating, it may be that your Intel on-board graphics are struggling to draw lots of object instances in the preview when populating complex objects with thousands of pokygons, thousands of times.
You can choose 'Hidden' as a display mode for all, or individual, problem objects. Each populator has this setting for individual objects and the 3D Preview has a global display mode with various other display settings. Check the little blue population box icon options above the 3D Preview window. :)


I agree, it actually could well be a problem with the graphics card or, more often, the graphics card *drivers*. Try without the 3D preview and/or hiding the population instances.

Have you done rendering tests without populations? If it renders OK, then that would probably rule out heat/load issues. It could still be memory-related though.

As for allocating more resources to TG, no, TG basically uses as much as is available in your system. The only way to give it more resources (RAM) would be to close other non-essential programs while it's running. 4GB of RAM is pretty small these days, it *will* be limiting on what you can make. But you should be able to do some basic small populations as you show in your screenshot. Unless other settings are unusually high.

- Oshyan


Hmmm, you already have it only showing bounding boxes I see from your image now, and not even very many of them. I still think it's a graphics problem, though. Maybe try to update the display adapter driver or, roll back to an older one, that might help, too. I don't know what is the best on-board Intel driver, usually the most recent one is advised but it mightn't agree with TG on your machine.


I think I only have 2gb RAM in my box just now and I can populate complex geometries far more densely than the settings you've posted. I don't think it's memory related.

* I don't know what a 'pokygon' is but I like it. Typing on a small Android. *


"This year - a factory of semiconductors. Next year - a factory of whole conductors!"


Turning off the 3d view did the trick - and I was able to render and add more populations and render these too! (screenshot attached).

It crashed when I brought back the 3d view - but not immediately, I was able to see the trees (bounding boxes) and change my viewpoint for a short while; it was when I went to the Camera tab I got the 'stopped working' error.

I will try experimenting as suggested with the preview and 3d view settings and hiding the populations - I'm currently rendering a view where the population preview was set to wireframe (if the render box appears I know it's going to work).

I think I might be saddled with the Intel graphics set-up. If I search for software online it says the best driver is installed- though yes, it might not be best for TG.  I don't know how I would go about rolling it back to test an alternative. If I choose to browse for driver software on my computer the Intel one appears, and "Standard VGA graphics adapter" which sounds a bit basic!

So,.. more things to try in TG itself re the 3d previews;  at the very least I suppose I could use a low res render to preview the scene.

Thank you all so much for your help on this - I was really stuck :)



I had the same problem. It ended up being my graphics excelerater.

I go in and disable it before doing the population. Then after population I save the project file. Enable the excelerater then reopen the project. Its a hassle but works


Sounds like it is the VGA card not the driver...but I used TG3 on a laptop that had Intel HD graphics without a problems...weird
Dell T5500 with Dual Hexa Xeon CPU 3Ghz, 32Gb ram, GTX 1080
Amiga 1200 8Mb ram, 8Gb ssd


Bit of an update on this: I found in the control panel the 'Intel Graphics and Media Control Panel'. I changed the 3d settings to accept the 'application settings' for various things (anisotropic filtering etc), and thought that sorted the problem for a while but it hadn't.

- I will see if I can find a graphics accelerator control - nothing obvious on the Intel options.

I've noticed that the populated preview works when the google-earth-style navigation controller at the top right of the 3d preview is off and there is just the small icon there in its place. The 'stopped working' error appears as soon as the controller is turned on (does that give any clues to what might be happening?)

Will have to see if its practical and can avoid crashes by hiding the populations temporarily just when need to use the navigator.   


sorry - scratch that bit about the navigator - it has crashed straight away (as soon as 'populate' button is hit) and using bounding box preview and wireframe even.  Has also now crashed when objects hidden! Will play more with display settings (the bit where I would access graphics acceleration in the display settings is greyed out).



Try here:

    Right click on the desktop and select select Screen Resolution
    On the window that opens up, click on the Advanced Settings link
    Select the Troubleshoot tab, then click Change Settings
    Move the Hardware acceleration slider towards none to reduce or turn off video hardware acceleration. d. Click OK, and then click Restart Now.
Dell T5500 with Dual Hexa Xeon CPU 3Ghz, 32Gb ram, GTX 1080
Amiga 1200 8Mb ram, 8Gb ssd