Error Message On Our Render Farm

Started by chrisS@422, August 08, 2014, 07:08:08 am

Previous topic - Next topic

chrisS@422

Hi Guys,
Getting a strange error message no-one can decipher on our render farm. The machine in question renders the frame, and is no different to other units we have. May be the PC but I just wondered if anyone's encountered this or similar messages before?

Error: Cannot convert from the charset 'us-ascii'!

Thanks for your help
Chris

jo

Hi Chris,

A bit tricky without more context. The only thing I could think of was it is an error from the XML parser we use for a lot of things, but that supports that charset. We do also use another XML parser for a few things but I'm not sure. Maybe check all the files the project is using to see if they're XML and see if they use that charset in the <xml> tag. If it's only happening on one machine and all machines are using the same files it seems unlikely to be that though, they'd all report the same error.

Regards,

Jo

jimw@422

Hi There,

I'm a colleague of the OP, and I can confirm that the error only occurs on the one Machine.

The main problem with this is it flags the system on Muster as unable to render that job so after completing a single frame it sits idle until the flag is reset.

I've attached a relevant log file.

Any help would be much appreciated.

Thanks

Jim

Oshyan

That's a strange error. It's quite uncommon but I don't think it's unique to TG. Is there anything unusual or different in the locale settings of that machine?

- Oshyan

jimw@422

Hi There, Thanks for the reply

No it renders Maya (Mental Ray and Maya Software etc.) and After Effects through muster just fine. I suspect that a complete reinstall of windows would solve the problem but unfortunately that's not an option on that particular system at the moment, so if anyone has got a suggestion of how to fix it (I have Googled it but to no avail), weather its a windows component or whatever than it would be very much appreciated.

Thanks

Jim.

Oshyan

I didn't mean to suggest that other software would necessarily be throwing the same error in this situation, just that the error itself is not overall unique to TG. There are hits on Google for it with other software. If it were an error we're explicitly throwing I think it'd be easier to track down but I don't think that's the case.

I'm kind of at a loss unless Jo has other ideas. The one thing I'd try is switching the locale/language settings and seeing if it happens still. Or try switching them to something else, then back to what they are now (and of course ensure they're the same as other machines).

- Oshyan

jimw@422

Thanks for the reply, I shall try the switching locale thing as soon as our systems are fully back up and running (were having the walls painted and the carpets cleaned at the moment so most things are piled up in the center of the floor including the systems in question).

I also though about uninstalling the windows 7 service pack 1 then reinstalling it. maybe that will sort this ASCII error.

Kind Regards

Jim