Depth of field test

Started by Kadri, August 26, 2014, 04:21:19 am

Previous topic - Next topic


August 26, 2014, 04:21:19 am Last Edit: August 26, 2014, 04:49:22 am by Kadri

I hadn't tried the depth of field feature at all since today.
Nothing artistic just to see the feature at work.
It is all Terragen with no postwork .



That is really sweet! Tg is not used much for this kind of stuff. I understand why, its not optimized at all for it. But the power is there!.. If you can figure it out that is, which some can... But I never can >:(

That could just as easily be a zombie virus conecting to a DNA, Kadri  ;D

Though Im betting controlling the animation of the object (how it moves) is a good bit of work more than it should be?
It has been eaten.



August 26, 2014, 06:08:30 am #3 Last Edit: August 26, 2014, 06:27:04 pm by Kadri


In a way it was not so hard to move Michael.
I tried to place the powerfractal displacement locally on the object
(when it moves the powerfractal should be moving with it).
But some things i tried didn't work and i didn't search here for a solution.
I cheated in that i transformed-moved the powerfractal displacement in the direction the sphere was going.
It wasn't perfect and don't needed too. The little difference gave a little acceptable displacement more even on it.
I should have used a planet node for this and to put some smaller things on it.

Not a priority for Planetside probably but all objects should have an option to move shaders with them.

A plane object that you can easily rotate without cosinus,sinus etc.
(i have seen the link where Matt explained it...)

All objects should have inputs for transform nodes.

There were some other problems too.
I haven't posted on the support board because i am not sure where the problem is.

The objects on the far side are Terragen rock objects.
When i changed some settings i could not see any difference until i took the node links off and on again.
Then when i disabled the rock object in the population node it still rendered.
I won't use the rock object other then for from now on :)
I remember that they were problematic in the past and this was the first time i used them.

The renders had square bucket line errors in some of them.
Depth of field problem maybe?
I changed many things so i don't remember what the solution was.
Because of the fast render times i changed the sampling method to Max samples(non-adaptive).
Maybe that was it, i don't know.

If there are already solutions to the above i am happy to hear guys :) (no sarcasm)

Edit: Here is the original mp4 file. It is a little bigger and sharper(!)



August 26, 2014, 06:20:06 pm #6 Last Edit: August 27, 2014, 11:04:10 am by Kadri


This looks indeed cool! Very unusual use of TG!