Problems with obj imports

Started by Marty, October 02, 2014, 08:49:59 pm

Previous topic - Next topic

Marty

Yes, objects should be ok. But something wrong with my Terragen. Tried many things here now: Reinstalling, tried with new startup-files etc. Just have to keep on trying.

Marty

Terragen works just fine if I do not import any object files (tgo files work great): If I do import a obj file they end up like a my picture above of the tiger or a line (as with the sphere).  And if I then go to File/New the new scene is just a mess, so I have to restart. But no object no problem. So this must be some kind of bug realted to obj import who for some reason kicked in now.

Oshyan

This is a very odd problem indeed. I can't think of anything off-hand that would immediately explain all of your apparent symptoms. But let's start with what we know. The TGD you posted is broken, as others have said. Even though you can see nodes in the Node List views on the left, the Node Network view bottom-right shows nothing and rendering the scene shows nothing as well (even if you change it from 0 detail, which is how it loaded here). I suspect you may not be seeing this same issue because the decimal separator in the entire file is a comma , instead of a period . Now what's odd about that is we have a lot of users in Germany and other places where the comma is used as a decimal separator and I've never seen this issue, so I'm not sure what that's about.

That being said, if the TGD you posted loads *and renders* correctly for you, it suggests your system is handling the decimal separator correctly, even though it's not the "standard" environment for TG3. Once I change the decimal separator to use period instead of comma, that scene renders just fine on my system. The question is whether it renders correctly for you. Is this just an issue you see *in the viewport*, or is it a render issue too? In which case show us what the rendered view looks like as that will be helpful. If it renders OK and you just see this issue in the 3D Preview window, then I would suspect it may be graphics driver related, which could explain why it just started a few days ago and worked before (assuming you upgraded your drivers recently).

- Oshyan

Dune


Marty

For the error to kick in I have to import an Wavefront Obj (tgo works fine): Object files ends up looking like this (rendered version of the tiger obj in my first picture): So it no longer any point for me to import Wavefront Objects.

Terragen it self do not change right a way on my side when it comes to comma and periode: BUT ( Look for next post:  )

Marty

If I after importing a Wavefront OBJ file go to FILE/NEW Terragen is messed up on my side to: Render image like the blue image under: And period is replaced with comma: Look at my two pictures from the render node (detail shoud be 0 on one of them but I changed it up to 0,1 so that you can see that the node now uses comma): If this is the problem, where do I change the comma period setting, or was it something you did in the file text itself?

Marty

October 04, 2014, 02:01:44 pm #21 Last Edit: October 04, 2014, 03:23:17 pm by Marty
So I underline: The problem comes if I import Wavefront Objects: I installed the free version of Terragen 3.1 on another computer and imported the same Tiger object: It worked great! :S

Marty

October 04, 2014, 05:33:01 pm #22 Last Edit: October 04, 2014, 05:42:08 pm by Marty
I have to correct what I wrote earlier: Terragen changes from using period to comma in all it's nodes from the moment I import a Wavefront OBJ file. I do not have to go to FILE/NEW to see the change. Strange.  On my test computer, where I installed the free Terragen, the nodes still uses period after I import the tiger and everything works fine. But as I am "new" to Terragen I do not know where to change between comma and period as a decimal separator? Anybody?


Marty

Thats exactly what I have been doing just now not knowing this was a Win 7 problem. Has not solved the problem but I it seem logical that it is something in this direction as I have Win 7 and have used Norwegian until now. But if anybody knows anything more or have an idee I would love to hear :)

Dune

Maybe it's your OS language related, because if I start a session of TG on Dutch windows, the first thing that I type is replaced by a hyphen. I've been used to that bug now for years, but I can imagine if you start TG and immediately import something, characters be get swapped or something.

Marty

October 05, 2014, 03:21:31 pm #26 Last Edit: October 05, 2014, 03:41:02 pm by Marty
I think I solved it! :D Should have solved it yesterday as I was closing in on the problem, but stopped as I got tired of sitting in front of the computer. Thanks Oshyan, Kadri and Dune for your help! Could not have solved it without you! It was of course related to comma and period, and this was again of course related to Win 7. It didn't help if I changed the language (maybe it should?), but if I manually typed in period as a decimal separator where Win 7 had placed a comma in Region and Languages: Formats : More Options (it's in Norwegian on my side now so it may not translate to exactly what I am writing) it was a fix. If I was more of a Win 7 expert I should of course have known right a way where to change from comma to period from what Oshyan said, but I have never had to do this before. Again: Thanks for the help! :D

PS! Strange that it did not work after I changed the Format language yesterday and that I had to type in the period "manually": I dont want to mess it up again so I will not myself try to change back and look for a solution to that question.

Marty

October 05, 2014, 03:28:58 pm #27 Last Edit: October 05, 2014, 03:50:23 pm by Marty
Restarted Terragen and loaded the tiger twice so I believe that the problem is a fix! Here is the tiger looking good, and Terragen has not gone from period to comma as a decimal separator in the nodes after the import! :D Life is good again! :D Thanks to you guys on page 1 of this thread too for input as I forgot to mention you above! :D

Oshyan

Glad you were able to fix it! It does seem strange that you had to change the decimal separator manually, but perhaps this allows you to have Norwegian language setting, but keep period for decimal separator, and thus solve the problem without changing your language (in other words if the decimal separator is not linked to the language).

Anyway, a unique problem and good to know about.

- Oshyan

Marty

October 05, 2014, 09:40:14 pm #29 Last Edit: October 05, 2014, 09:44:36 pm by Marty
All in all I still think the soultion in general to this problem must be the one in the link Kadri posted about Win 7: http://www.copsmodels.com/gpcommapnt.htm . Either I did something wrong or maybe it wasn't enough to change Format language (I changed every language setting possible) on my side (as I said: It all worked fine with the same settings a week ago): Maybe just some strange incident in my Win 7 that required me to put in the period manually.