Author Topic: 3.3 Soft Reflections bug  (Read 970 times)

Offline fleetwood

  • Member
  • *
  • Posts: 1232
3.3 Soft Reflections bug
« on: August 12, 2015, 12:45:51 PM »
Soft reflections seem to have some sort of bucket matching problem using the latest version. Anyway here is a what I'm getting and the very simple test file.
« Last Edit: August 12, 2015, 02:28:21 PM by fleetwood »

Offline Oshyan

  • Planetside Staff
  • *
  • Posts: 13097
  • Holy snagging ducks!
Re: 3.3 Soft Reflections bug
« Reply #1 on: August 14, 2015, 07:45:45 PM »
You are probably using values that are too high for the number of soft reflection samples you are using. The soft reflection setting should use very small values to avoid sampling issues. 0.001 I believe is a good starting point, and you can maybe try values up to 0.005 or 0.01 perhaps, but you will need to increase samples to get good results.

- Oshyan

Offline fleetwood

  • Member
  • *
  • Posts: 1232
Re: 3.3 Soft Reflections bug
« Reply #2 on: August 14, 2015, 08:16:11 PM »
Thanks for explaining Oshyan
I seldom use soft reflections. I should have remembered that the working range is in that neighborhood of  .001.
I see that it takes 32 samples to get a smooth result with the extreme value of  0.05 softness in my test.

Offline Oshyan

  • Planetside Staff
  • *
  • Posts: 13097
  • Holy snagging ducks!
Re: 3.3 Soft Reflections bug
« Reply #3 on: August 14, 2015, 08:34:16 PM »
Yes, exactly. It's rather a finicky setting. Hopefully we'll be able to improve that in the future. :)

- Oshyan