Colour Contrast / Softness

Started by WAS, December 30, 2015, 02:22:46 am

Previous topic - Next topic

WAS

On a default Power Fractal, dropping Colour Softness to 0.25 and increasing Colour Offset to 0.25 causes a crash
Check out my Terragen Discord: https://discord.gg/Vy5FRTE

Dune

Not when I do it.

WAS

Hmm, interesting. The node I was working on wasn't connected though, it was created outside the network.

I started with colour roughness, then adjusted offset. First time I used the slider and all was fine until I hit 0 and started back up. Crashed every time I enter 0 for 0.25 manually.
Check out my Terragen Discord: https://discord.gg/Vy5FRTE

Dune

Maybe it has nothing to do with the PF by itself, but is it the preview refreshing ánd at the same time changing some value wherever; I get crashes when I do that (quite often, actually).

WAS

Quote from: Dune on December 30, 2015, 11:04:57 am
Maybe it has nothing to do with the PF by itself, but is it the preview refreshing ánd at the same time changing some value wherever; I get crashes when I do that (quite often, actually).


Could very well be it, I don't usually pause the preview unless I am getting slowdown.
Check out my Terragen Discord: https://discord.gg/Vy5FRTE

WAS

I think I mentioned this before; there should be a timeout for inputs. I've notice most crashes do stem from the preview window and entering in inputs or dragging sliders. I think a simple fix would have Terragen not recognize these inputs into focus is removed (like a lot of applicatons) or to simply have a timeout after input has stopped, like a second or two. This would allow the preview to hopefully catch up before things are dramatically changed too fast.
Check out my Terragen Discord: https://discord.gg/Vy5FRTE