Call for Beta Testers: Terragen 3.4

Started by Matt, February 19, 2016, 10:26:50 pm

Previous topic - Next topic

bobbystahr

Quote from: Chris on February 26, 2016, 06:51:00 pm
Quote from: bobbystahr on February 26, 2016, 05:15:27 pm
Anyone getting any crashes. I just got one editing a texture on a .tgo. Just changing maps. Very odd.


I will have to check that out on my end and post here is the same problem arises.


Coincidentally it was on your medium size Round Fescue...I wanted it browner and more desaturated but it didn't like my map and bye bye project(recently saved tho)
something borrowed,
something Blue.
Ring out the Old.
Bring in the New
Bobby Stahr, Paracosmologist

bobbystahr

Quote from: Oshyan on February 26, 2016, 10:29:20 pm
Quote from: bobbystahr on February 26, 2016, 05:15:27 pm
Anyone getting any crashes. I just got one editing a texture on a .tgo. Just changing maps. Very odd.


Can you reproduce the crash? Was there any error message or other diagnostic info?

- Oshyan


Try changing the texture on the medium round fescue that Chris shared Oshyan...
something borrowed,
something Blue.
Ring out the Old.
Bring in the New
Bobby Stahr, Paracosmologist

AP

Using a combination of jpg, tiff and bmp. No crashes.

N-drju

February 27, 2016, 01:06:48 pm #48 Last Edit: February 27, 2016, 01:10:57 pm by N-drju
Yay! I broke the timer... :P

So I wanted to be an asshole just this once and clicked "Render image" while TG was already rendering an image. A message popped up that the program is already rendering so I clicked ok.

The render froze for a moment and timer stopped to count the time. Then I clicked pause and when I unpaused it the timer did not show up again. I have "Rendering..." message with no time count to be seen. :P

When the render was complete the final elapsed time showed the point when I interrupted rendering.
_______________________

Also, upon saving I entered diacritic marks (ą, ś, ć to be specific) and got the message...

Unknown filter selected: Please report this to Planetside Software

So here I am. :P
"When dictatorship is a fact, revolution becomes a right."

fleetwood

3.4 Crashes in Windows in the following situation  :
Begin a render with that has multiple populations that normally take two or three minutes to populate.
Without waiting for the population progress window to finish Close out the preview window
Immediately Minimize the Terragen window
Immediately Minimize the Render window

The small population windows continue to pop up on the screen with the percentage of completion. Then there is a crash, seemingly upon the last population popup completing.

I only found this out when intending to leave the house and have the render running for several hours and wanting to have the computer screen not updating while the render proceeded.
Leaving all Terragen widows up on screen until the populations are done lets the render complete normally.

N-drju

Quote from: fleetwood on February 27, 2016, 02:39:43 pm
3.4 Crashes in Windows in the following situation  :
Begin a render with that has multiple populations that normally take two or three minutes to populate.
Without waiting for the population progress window to finish Close out the preview window
Immediately Minimize the Terragen window
Immediately Minimize the Render window

(...)

I only found this out when intending to leave the house and have the render running for several hours and wanting to have the computer screen not updating while the render proceeded.
Leaving all Terragen widows up on screen until the populations are done lets the render complete normally.


True - this happened to me to. When I clicked through various windows while populating, minimized them etc. I got crashes about 20% of the time.

Actually this has been an issue in previous releases as well. Probably it's not wise to move or play with any windows before populating is done...
"When dictatorship is a fact, revolution becomes a right."

AP

No issues here with the Beta concerning this or any other previous version. Populating, i would imagine is somewhat taxing when calculating before completion.

Dune

It's like moving the ladder you're standing on.... crash  ;)

AP

February 29, 2016, 07:58:41 am #53 Last Edit: February 29, 2016, 08:56:45 am by Chris
 :)

otakar

Matt and Oshyan, is there a deadline you want results by? No issues here so far.

Oshyan

Quote from: otakar on February 29, 2016, 01:29:26 pm
Matt and Oshyan, is there a deadline you want results by? No issues here so far.


We hope to make the release within the next couple weeks, the sooner the better. We need to give adequate time for testing, but in the end not everything can possibly be tested, and the most important thing is that things are improved vs. the previous version, and no new issues are introduced. So far I think that is generally what we are seeing. These population crash issues are something we'll look into, but it sounds like 3.4 is no worse in that regard than 3.3 was, at least. And if that's the case I don't know if it would be considered a "blocking" bug for the 3.4 release. It's something we'd ideally fix, but he circumstances of that crash are pretty specific and avoidable at the same time.

- Oshyan

bla bla 2


Clay

Can't see 2D clouds in the preview window...

Oshyan

2d clouds are showing for me. Are you *above* them looking down? That has never worked as far as I know. Use 3D clouds in that case.

- Oshyan

Clay

Quote from: Oshyan on March 09, 2016, 11:17:30 pm
2d clouds are showing for me. Are you *above* them looking down? That has never worked as far as I know. Use 3D clouds in that case.

- Oshyan
I can post a screen capture? Buuut am not seeing a add image option..???