Render speed improvements?

Started by redstamp, September 04, 2007, 01:06:31 pm

Previous topic - Next topic

redstamp

I have a Dell P4 3GHz with 2GB RAM, running XP and Terragen 0.09.43

My final render (4000x3000) took over 30 hours to complete, and yet only ever used 50% CPU and about 200MB RAM, when there was clearly much more computing power available. I was not using any other apps (except for TRAM render manager) and the 'system idle' process was the next highest user of CPU. Masses of RAM remained available.

I tried making the Terragen process 'realtime' priority in the Task Manager and this did nothing.

Does anyone know how to improve the render times of Terragen?  Presume Render Memory Buffer setting may improve things but cannot find out what I should set this to?

If I did buy a faster CPU or add more RAM, would this make a difference?

Any help gratefully received!

Regards,
Jon.

Volker Harun

The 50% usage ... is it possible that you have a dual core CPU? TG0.9 is not multi-processor capable. What you can do is to start two instances of TG0.9
Each instance is set to another core (in the taskmanager). Load in each the scene, but in one you rotate the camera by 180°.
This should reduce the rendertime by 50%.

Oshyan

I believe this question was answered on the Yahoo Group. Essentially your P4 is seen in Windows XP as having multiple CPU's but really it is just the "hyperthreading" function which provides a "virtual CPU". This is not the equivalent of a full 2nd CPU and taking advantage of it would only improve render time by 10-15%. It would require multithreading to do so and this is not something that will be added to TG 0.9 as all our development effort is now focused on TG2. Multithreading will be available in TG2 in the future.

- Oshyan

efflux

October 09, 2007, 04:12:47 pm #3 Last Edit: October 09, 2007, 04:14:48 pm by efflux
My P4 3.0 GHz are hyperthreading. Windows XP home cannot utilize it properly anyway. I turn it off in the bios. This is another reason why Linux blows Windows away on my PCs because it can handle this.

efflux

Apparently SP2 for Home was optimized for Hyperthreading. I don't instal that but maybe the HT is improved now. All I know it that HT was better disabled with Windows SP1 but enabling it with Linux made a noticable difference to the performance of even the OS.

old_blaggard

On a side note, I read that Microsoft is prepping SP3 that includes more than 1000 bug fixes :o.
http://www.terragen.org - A great Terragen resource with models, contests, galleries, and forums.

efflux

There was a bug in SP1 (I think) which cut off USB ports not being used. I spent ages on this. I thought there was a problem with my motherboard, which was new at the time, only to discover it was a Windows bug. There are thousands of them and hence why I love my Mac.

I don't understand this hyperthreading thing because when I initially built my PCs I read on the MS site that HT was only supported by XP Pro. Now I'm reading different.

schmeerlap

You have more processing power than I have. I also render at 4096x3072 and even with oceans of water, heavy atmosphere and 3d clouds I rarely have a render that excedes 8 hrs. I suspect you may have your Extra Blended Detail checkbox checked in your Render Settings > Quality tab. If so, uncheck it, but keep the Ultra checkbox checked. You won't lose any discernable quality but your render will be approx. 4 x faster. The EBD checkbox is only usefully checked when doing animations. I have my buffer size (Render Settings > Advanced tab) set to 256Mb for large renders, I find anything higher is redundant.
I hope I realise I don't exist before I apparently die.