cast shadows from invisible obj

Started by radix, November 13, 2016, 09:11:33 pm

Previous topic - Next topic

radix

Hi everyone,

I've imported some cubes from maya into terragen. I would like for the cube visibility to be turned off, but for the shadows cast by the cubes to still appear on the landscape. Is this possible? Or is it possible to render shadows cast from an object as a separate matte?

I thought I could just go into the obj's rendering tab, switch Render to Invisible, and leave Cast Shadows on, but nothing appears to happen. I've been mucking with Render Layers as well without much luck.

I assume this is possible but I'm struggling with it...

Kadri


Make a new group and try this:



[attachimg=1]

radix

Hey Kadri, thanks for the help, but I couldn't get it working on my end. If that worked for you than think I'm missing something elsewhere because the cubes are still showing up in my renders:

Dune

I don't see the problem, actually. This was TG3, but still should work.

Kadri

November 14, 2016, 04:18:16 am #4 Last Edit: November 14, 2016, 04:20:42 am by Kadri

That is confusing. Your scene renders as it should on my side.
This is a direct render of your scene.


radix

@Kadri - very strange :(

@Dune - It looks like the cube you're using originated within Terragen, e.g. it wasn't imported using the obj reader. I tried the same, just setting render to invisible and leaving cast shadows checked, and got the same results as you. Seems like it's just the obj reader that's giving me trouble.

I did a new test, exported a new cube from maya, imported it into terragen with the obj reader. It seems like even when I change the cube's settings, nothing updates in the actual render (see attached).

At a loss... I feel like there's just some setting ticked somewhere that is doing this, or i'm missing something really obvious... Sort of hard to troubleshoot if it's working for everyone else. Using the pro version of tg4, btw.

Kadri


I use Windows 10, yours looks like a Mac ?
Any Mac user who could test Radix Zip file above?

radix

Thanks Kadri, yeah I'm on a mac,  10.9.5.

Anyone else out there ever encountered this? Can anyone on a mac test the tgd?


Dune

That is weird indeed, looks like a bug, to be honest.

Oshyan


radix


bobbystahr

Quote from: radix on November 14, 2016, 10:45:40 pm
@Kadri - very strange :(

@Dune - It looks like the cube you're using originated within Terragen, e.g. it wasn't imported using the obj reader. I tried the same, just setting render to invisible and leaving cast shadows checked, and got the same results as you. Seems like it's just the obj reader that's giving me trouble.

I did a new test, exported a new cube from maya, imported it into terragen with the obj reader. It seems like even when I change the cube's settings, nothing updates in the actual render (see attached).

At a loss... I feel like there's just some setting ticked somewhere that is doing this, or i'm missing something really obvious... Sort of hard to troubleshoot if it's working for everyone else. Using the pro version of tg4, btw.


Have you tried running the ,obj through PoseRay prior to importing into TG? Pose Ray fixes all kinds of quirks for me.
something borrowed,
something Blue.
Ring out the Old.
Bring in the New
Bobby Stahr, Paracosmologist

bobbystahr

Here is a cylinder I created in Imagine 3D which does no U/V mapping so after converting it to .obj in Deep Exploration I ran it through PoseRay to get mapping and texture which you see in the preview on the right....on the left only shadow
something borrowed,
something Blue.
Ring out the Old.
Bring in the New
Bobby Stahr, Paracosmologist

radix

Hey Bobby, thanks for the suggestion, does PoseRay have a version for Mac? The only version I found was for windows. At first I thought this visibility issue might be a problem with the obj, but then it worked fine for Kadri on his windows machine, so perhaps it's just a mac based issue, some sort of bug

bobbystahr

Quote from: radix on November 17, 2016, 01:00:49 am
Hey Bobby, thanks for the suggestion, does PoseRay have a version for Mac? The only version I found was for windows. At first I thought this visibility issue might be a problem with the obj, but then it worked fine for Kadri on his windows machine, so perhaps it's just a mac based issue, some sort of bug


D'oh, sorry about that...I will happily run them thru for you as PoseRay keeps avoiding that issue...but if it worked fine for Kadri...hmmm, maybe you're right. Still if y wanna try I'm game.
something borrowed,
something Blue.
Ring out the Old.
Bring in the New
Bobby Stahr, Paracosmologist