TG4 camera interpolation bug

Started by Accumelator, December 17, 2016, 06:05:20 pm

Previous topic - Next topic

Accumelator

Hey All,

I think I have found a pretty bad bug. "the camera interpolation is not working between side by side key frames"

the simple test: (perspective camera)

- add some terrain, some atmos/clouds
- set a camera key at F10 with random numbers, for example T 5500,8800,2800 R 0.5 -40 0.0 FL 50mm
- set a camera key at F11 with random numbers, for example T -5000, 8300, 0.5 R -11 92 2.0 FL 35mm

render F10: looks correct
render F11: looks wrong
render F12: looks correct

If anyone has a current workaround please post reply

Thanks !


Matt

Welcome to the forum!

In what way was it different from what you expect? Can you show us a render and describe the problem?

Matt
Just because milk is white doesn't mean that clouds are made of milk.

Accumelator

Hey Matt,

attached image shows the issue

- snippet of the animation panel showing 2 key frames, one at 945 the other at 946, interpolation is linear (I even tried TCB with 1 bias)
- low res render of frame 945,946,947, showing clearly 946 is wrong and lives somewhere between 945 and 947
- RTP preview render of those same frames, showing RTP interpolates correctly for all 3 frames

Accumelator

Hey Matt,

here is the standard scene with some key frames applied to frame 1-5,6-10. render frame 6 and you see the same problem

Kadri

December 18, 2016, 09:05:32 am #4 Last Edit: December 18, 2016, 03:16:07 pm by Kadri

If you use "Start on frame" (Blur tab in the Camera node) the preview and render will be the same.
From Matt's post here below it looks like the best is to make "Length" zero in the "Blur" tab.
It is the best to be sure that there is no motion blur at all.
http://www.planetside.co.uk/forums/index.php/topic,17773.msg172163.html#msg172163

And yes it can be confusing. There should be a warning of some kind probably if you disable the "Motion blur" in the render node.

Accumelator

 :o OMG  :o

That totally solved it. Now I am hitting myself for not finding this earlier.

It totally makes sense.

I do agree that it would be nice that when "motionblur" is set to NO, it would automatically already do this internally.

Thanks so much for the quick response and solution.