Martin's landscapes

Started by Martin, July 31, 2017, 01:33:05 am

Previous topic - Next topic

Martin

Quote from: luvsmuzik on February 01, 2018, 08:48:08 am
My first guess would be angle and elevation of sun. You have it directly opposite rockface, correct? You might need second sun, w/o shadows and low intensity for better light.

Is that one pop of transmitter/receivers or two?

No, it's a bug for sure, the sun is directly above the landscape (85 degrees) And as you can see two population members right next to each other have different lighting, one is fully illuminated, the other is only with indirect lighting.There's nothing to cast shadows on them.  Never seen anything like this.

The transmitters are another population.

luvsmuzik

Might have to do with subdivision cache if you have rechecked all your texture shaders on object.

Martin

Quote from: luvsmuzik on February 01, 2018, 08:57:29 am
Might have to do with subdivision cache if you have rechecked all your texture shaders on object.

I'll have to check, could be a memory problem(?)


Martin

Made a mine, and some heavily eroded pyramids from the far future btw


Hannes


Matt

Quote from: Martin on February 01, 2018, 08:54:34 am
No, it's a bug for sure, the sun is directly above the landscape (85 degrees) And as you can see two population members right next to each other have different lighting, one is fully illuminated, the other is only with indirect lighting.There's nothing to cast shadows on them.  Never seen anything like this.


Do you have displacement on these objects? If so, it's probably the same problem as in this thread:

http://www.planetside.co.uk/forums/index.php/topic,20213.msg200683.html#msg200683

If you have negative displacement on the object, it goes dark because the shadows are cast from the non-displaced object. This is because the ray tracer (which is used for shadows) doesn't support displacement on imported objects yet. It requires a big change to the renderer to support this, but it is on the roadmap for the future.

You can usually solve this by adjusting any offsets you have in your displacement shaders.

Matt
Just because milk is white doesn't mean that clouds are made of milk.

Martin

Quote from: Matt on February 01, 2018, 03:24:38 pm
Quote from: Martin on February 01, 2018, 08:54:34 am
No, it's a bug for sure, the sun is directly above the landscape (85 degrees) And as you can see two population members right next to each other have different lighting, one is fully illuminated, the other is only with indirect lighting.There's nothing to cast shadows on them.  Never seen anything like this.


Do you have displacement on these objects? If so, it's probably the same problem as in this thread:

http://www.planetside.co.uk/forums/index.php/topic,20213.msg200683.html#msg200683

If you have negative displacement on the object, it goes dark because the shadows are cast from the non-displaced object. This is because the ray tracer (which is used for shadows) doesn't support displacement on imported objects yet. It requires a big change to the renderer to support this, but it is on the roadmap for the future.

You can usually solve this by adjusting any offsets you have in your displacement shaders.

Matt

Thanks for the tip, sadly no displacement on those objects, so the problem must be something else.I'll try to make a test render in another scene with the same obj population, to see if something's wrong with the model itself(I made it in 3ds max)


Oshyan

Quote from: luvsmuzik on February 01, 2018, 05:16:46 pm
maybe recalculate normals


Agreed, that was my first thought - either normals or some other modelling-related issue, e.g. quads, etc.

I don't know what it would have to do with the subdiv cache? What did you have in mind there??

- Oshyan

luvsmuzik

Quote from: Oshyan on February 02, 2018, 12:28:25 am
Quote from: luvsmuzik on February 01, 2018, 05:16:46 pm
maybe recalculate normals


Agreed, that was my first thought - either normals or some other modelling-related issue, e.g. quads, etc.

I don't know what it would have to do with the subdiv cache? What did you have in mind there??

- Oshyan


I only had in mind that it is an option that can be over-ridden. I did not know if this meant....hey you got a lot of stuff in that setup and my memory is not that great.....(my computer is speaking)....and Terragen might crash if you do not do something....

Ha! It was just a thought, since as you know my other unit was just a 4Gig that used to blackout once in awhile.

Martin

It's not that important anyway, I'm experimenting with the erosion shader again.

bobbystahr

And with lovely results...carry on heh heh heh
something borrowed,
something Blue.
Ring out the Old.
Bring in the New
Bobby Stahr, Paracosmologist

Martin

everyone's favourite: the Hadean era : )