BSOD when RTP 3D preview mode

Started by Denis Sirenko, August 26, 2017, 12:01:36 pm

Previous topic - Next topic

Denis Sirenko


Today I worked all day in Terragene 4.1.11. Overall, I'm pleased with the increase in overall performance. Many thanks to the developer for the great product! But there is a problem that I can confidently associate with the latest update. In the previous version I did not encounter this. The my problem is the appearance of the BSOD, when the preview window works in RTP mode and I change the parameters inside the node. Basically, render objects are: Light sources and Cloud layers v3, Cloud fractal shaders v3 and Power fractal shaders v3 on warp input shaders. Today I saw BSOD three times! I think that this is not normal and I'm a little scared for my computer.

My system:
Windows 10 Home x64
Intel Core i5-4440 CPU 3.10GHz
Terragen version 4.1.11

Unfortunately, I do not know what information should be provided to developers in this case. Ask and say everything you need. I would be grateful if you would correct the problem or tell me what to do. I would not want to return to the previous version of the program.

Thank you!

PS: It's good that the draft of messages on the forum is periodically saved! Now I was trying to make a screenshot of what the program looks like at the moment of provoking BSOD and the BSOD appeared for the fourth time. I changed the Cloud depth parameter in the Cloud layer v3 node. As in the screenshot.


Hi Denis, I'm sorry you're experiencing such severe issues!

Is it actually a BSOD, or just a crash?

BSOD's usually indicate some deeper issue, either hardware or driver-related. In normal circumstances *no* application (including Terragen) should be able to "cause" a BSOD on its own. Especially in Win10 where there is even more driver and low-level system protection. It's possible for Terragen to be making a request to the driver that it then handles in a way that causes a BSOD, or for TG to be exposing some issue in the hardware, for example memory, but it's highly unusual for the application itself to be "causing a BSOD".

I would also say this seems to be system-specific because it's the first report we have had of it (although there have been other reports of crashes at times, it's true, but no BSODs as far as I know).

Does it seem to occur all the time, or only when editing specific settings or in other specific circumstances?

- Oshyan

Denis Sirenko

August 28, 2017, 03:59:57 am #2 Last Edit: August 28, 2017, 04:09:28 am by Denis Sirenko
Oshyan, thank you. I will continue to work, and as the problem recurses, I will collect information and statistics. Now after a fresh boot of the system, I tried to record a video, as the problem appears, but nothing happened, everything is still working well.

Now I'm not sure that this is the BSOD, because I don't know what the difference between the BSOD and the system crash. I will try to understand in what cases this happens. Thanks for the answer!

Denis Sirenko

Quote from: Oshyan on August 27, 2017, 03:07:59 pm
Does it seem to occur all the time, or only when editing specific settings or in other specific circumstances?

No, it does not happen all the time. As I just said, I could not reproduce the crash now. But this is definitely connected with the actions in the node's settings and it seems to me that the RTP mode is also involved here, because there was never such a time, when there would not be a PTP mode of 3D preview window. Also I'm not sure what specific settings are to blame. Basically I'm working with the settings of the geometric form in the nodes Cloud layers v3 and Power fractal shaders v3. For now that's all I can say.


OK, thanks for the additional info. Definitely let us know if you can provide any other specific details.

A Blue Screen of Death will literally be a blue screen. Windows will tell you an error has occurred and it is unrecoverable and it may tell you it is gathering crash data and then restarting. A system crash might be more like a total system "hang" (the computer becomes unresponsive, no inputs work, but no BSOD shows), or a spontaneous reboot. There are also the more common (and more likely to be caused by an application's programming) basic crashes, etc. where the application shows an error, or simply quits forcefully and without warning.

- Oshyan

Denis Sirenko

I understood. It's definitely BSOD, and I have a fresh photo. It's new today's BSOD.


And at the moment I performed the render quality adjustment, or just started performing -- I'm not sure I managed to enter a new value of the Micropoly detail. In general, now I'm not sure that this is generally associated with changing settings. But 3D preview mode was again RTP. In any case, I collected all the information which gives Windows. In the archive bug check information (txt). I will be grateful if you find the opportunity to see it.

I also made a dump of memory, the weight of which is 220 MB. If this can help, I will send the file to you by e-mail or personal message.

Denis Sirenko

And one more... This time I did not touch the settings of nodes, but the Terragen still fell. Now I'm trying to disable the sound card. On other computers in our studio, sometimes there was such a problem. I also saved the memory dump.

Windows's description:

The computer was rebooted after a critical error. Error code: 0x0000007e (0xffffffffc0000005, 0xfffff80ce9add98e, 0xffffd001a271f398, 0xffffd001a271ebe0). The memory dump is stored in the: C:\WINDOWS\MEMORY.DMP. Report code: 00000000-0000-0000-0000-000000000000.

- System
  - Provider
   [ Name]  Microsoft-Windows-WER-SystemErrorReporting
   [ Guid]  {ABCE23E7-DE45-4366-8631-84FA6C525952}
   [ EventSourceName]  BugCheck
  - EventID 1001
   [ Qualifiers]  16384
   Version 0
   Level 2
   Task 0
   Opcode 0
   Keywords 0x80000000000000
  - TimeCreated
   [ SystemTime]  2017-08-28T11:57:01.084476800Z
   EventRecordID 7252
  - Execution
   [ ProcessID]  0
   [ ThreadID]  0
   Channel System
   Computer INTERFACE
- EventData
  param1 0x0000007e (0xffffffffc0000005, 0xfffff80ce9add98e, 0xffffd001a271f398, 0xffffd001a271ebe0)
  param3 00000000-0000-0000-0000-000000000000

Denis Sirenko

Kadri, thanks, I know about it. Actually, the information I published here I found in the Event Viewer :) But anyway, any advice can be useful, thank you!


Quote from: Denis Sirenko on August 28, 2017, 11:01:47 am
Kadri, thanks, I know about it. Actually, the information I published here I found in the Event Viewer :) But anyway, any advice can be useful, thank you!

Thought so, but posted just in case :)


Unfortunately there is really not much information in these error logs. But the message you are getting, "System Thread Exception Not Handled", seems to be frequently related to graphics driver issues.

See here:
"Blue screen error "SYSTEM_THREAD_EXCEPTION_NOT_HANDLED (igdkmd64.sys)" is typically caused by faulty Intel Graphics drivers."

And here:

Perhaps you can check for updates for graphics drivers?

- Oshyan

Denis Sirenko

Oshyan, thanks for info and links.

Yesterday I started the experiment. First of all I suspected an audio card, and I tried to turn it off. It did not work, the BSOD reappeared. And then I turned off my videoadapter and worked on the integrated audioadapter. And until the end of the day, I no longer had any problems. I think that you are right, that the video adapter is to blame. I checked the drivers, they are the latest version. Under your link I found information about this error, where I was advised to completely clean the system of old drivers and reinstall them. That's what I did. By the result I will inform you. Thank you!


Thanks for the update. I am glad that there may be some progress, even if it is not solved yet. Do let us know if you find out anything further.

- Oshyan

Denis Sirenko