[PROBLEM SOLVED] Atmosphere problems (bug, maybe?)

Started by Gothic, December 30, 2006, 05:22:35 AM

Previous topic - Next topic


So, basically, I was setting up a scene to render and I was messing around with the settings to see what they did, and suddenly, my atmosphere disappeared. In the 3D preview, everything is black where the sky is supposed to be. When I start the rendering, everything is fine (i.e. the little dots that appear at first are there and they're blue in colour where the sky is supposed to be) but at the end of the render, the sky goes black. I'm not sure what I did wrong, so could someone help me?

Edit: In addition, when I zoom out to view the whole planet, it becoms an empty ring.

P.S. First post here!


Can you upload something to show what you mean--a render, a screenshot of the preview, or the tgd file? It's hard to determine what might be the problem just based on your description.


Did you untick the enable option in the atmosphere shader by accident?


I've had renders where my atmosphere / sky came out black for no apparent reason, but it's nothing I can reproduce.  it seems very similar to how renders sometimes come out red or magenta or otherwise wrongly weird (or is that weirdly wrong?).  a simple jiggle of the camera and re-render has fixed it.

it's only happened once or twice for me - I get the red/magenta thing much more often.


Chiming in a little late here, but did you have the Cameras button along the top selected? For some reason, the atmosphere disappears when it is selected. But if you press the Lighting and Renderers buttons (on either side of the Cameras button) the atmosphere returns to the 3D preview window.


I viewed the 3D preview through all tabs and let it finish rendering, but still no dice. Also, the sky appears black in the 3D preview and the final render.

I'm rendering the image now to show you what I mean by those blue dots and the black sky.


Ok, done. I've attached the images that show what I mean.

As you can see, the sky looks like it's rendering fine in the GI pass, but in the final render, it turns a beautiful shade of inky black.


Did you turn on "Do reverse primary rays" in the Render Settings under More Settings? If so turn it off. :D

- Oshyan


Holy sh--... I feel like a retard!

Thanks anyway! It works fine now! What was the problem anyway?