Black Spots on the Water

Started by Aleksei, November 24, 2017, 04:46:46 pm

Previous topic - Next topic

Aleksei

Hi.
Does anybody know how to get rid (or at least reduce the number) of black spots in the water)?

I'm rendering image which is 10000 x 2000 px and here is the crop region from the render:


Micropoly detail: 0.3
Anti-aliasing: 1



Micropoly detail: 1
Anti-aliasing: 1



Micropoly detail: 1
Anti-aliasing: 3



As I understood there's something wrong with micropoly details. But increasing the value even up to 2 doesn't help that much.


Micropoly detail: 2
Anti-aliasing: 1

Your Multi-Tool of Design & Advertising: • NORDSKILL •

Oshyan

I think I would experiment with the various options in the Subdiv Settings area (accessed from the Render Node). You could try the "Check Animation Settings" button as a quick way to see if some of those settings would have an effect.

- Oshyan

D.A. Bentley

In the very first image it almost looks like those black spots are holes, like you are seeing through to your ground.  Is your water very close to the terrain / ground?

Dune

I think it has to do with calculation of reflections and transparency when 'faces' are very near to eachother. You also get black edge lines when making very shallow water e.g. (talking centimeters/millimeters), and higher subdivision settings (up to 1) and higher detail settings do help to get them out.

For water that doesn't really need transparency, you could also try a reflective shader replacing the reflections of the water shader (and transparency to zero), and use smooth (0.004) reflections.

sboerner

QuoteI think I would experiment with the various options in the Subdiv Settings area (accessed from the Render Node).


More on this here: http://www.planetside.co.uk/forums/index.php/topic,22318.msg224958.html#msg224958.

In this case, increasing Ray Detail Multiplier to 0.75 cleaned it up. But it took a very long time to render. Dune's suggestion about not using a water shader at all may be the way to go.

Eneen

Turning off "Fully adaptive" inside subdiv settings also fixes this.