2D Flame Project

Started by WAS, June 25, 2018, 03:29:19 pm

Previous topic - Next topic

WAS

Working on the idea of putting the flame shaders on a card but I'm having a few issues.


  • I am having issues locking in the opacity.

  • I am having issues with a unique "noise" slice per card pop. Is that possible?

  • I'm unsure how to create falloff on Z/X so the flames are cut off on the edges of cards.



Unsure what to do. If it could be made to look natural, it'd be a great alternative to clouds as it's super fast. Could be used to embers/sparks in the air too with different settings as I found out messing with the density fractal.
Check out the Terragen Community on Facebook: https://www.facebook.com/groups/Terragen.Galleries/

SILENCER

Ambitious, I admire the moxie this takes, but honestly, this is why we have fluid sims and compositors.

WAS

Quote from: SILENCER on June 25, 2018, 06:55:45 pm
Ambitious, I admire the moxie this takes, but honestly, this is why we have fluid sims and compositors.

Lots of added effort for something very simple, pretty redundant in fact for something as simple as flame licks in a still. That sort of outlook makes Terragen as a whole shelved for other software which can do the same things, in a fraction of the time, but that's not really what it's about from an artistic stand-point. Commercial maybe.
Check out the Terragen Community on Facebook: https://www.facebook.com/groups/Terragen.Galleries/

Dune

It's just nice to experiment, and get to know the capabilities of TG. And not everybody has access to all software, so if one gets something working within TG it may be handy for some users.

I added some nodes, but the black is still there. Just forget about this, I'd say. And also, I have wondered about (and mentioned) world scale opacity in pops one or two times in the last few years, but don't think it works as expected/needed (but haven't tried for a long time). It would be handy to make forest edges (on flat country) to have grazing edges (lowest branches eaten off), for instance.

WAS

June 26, 2018, 02:27:47 am #4 Last Edit: June 26, 2018, 03:23:42 am by WASasquatch
Quote from: Dune on June 26, 2018, 01:57:53 am
It's just nice to experiment, and get to know the capabilities of TG. And not everybody has access to all software, so if one gets something working within TG it may be handy for some users.

I added some nodes, but the black is still there. Just forget about this, I'd say. And also, I have wondered about (and mentioned) world scale opacity in pops one or two times in the last few years, but don't think it works as expected/needed (but haven't tried for a long time). It would be handy to make forest edges (on flat country) to have grazing edges (lowest branches eaten off), for instance.


I wonder if the black issue is created by the breakup/altitude falloff, where the black produced is "below" black, and not picked up by the opacity at all?

And yeah, though doesn't colour work for populations? Like varying colour of a forest with a PF? This seems to fall in line with that, which is odd. Maybe without the added "parts" shader it's not possible.

Thanks for the edits, going to take a peak.

Edit: I notice how just that generic surface layer and glass layer without being named causes the warpers to both disconnect?
Check out the Terragen Community on Facebook: https://www.facebook.com/groups/Terragen.Galleries/

WAS

Oshyan or Matt, do you have any input on the opacity issue? Is this because of the surface layers falloffs being below black or something?
Check out the Terragen Community on Facebook: https://www.facebook.com/groups/Terragen.Galleries/

Dune

You can try by adding a clamp color 0 1 function

WAS

Quote from: Dune on June 29, 2018, 02:59:05 am
You can try by adding a clamp color 0 1 function


That sounded so hopeful. Hmm. Really wondering what it is.
Check out the Terragen Community on Facebook: https://www.facebook.com/groups/Terragen.Galleries/

jaf

Maybe this is closer.... fed Base colors into the Flame Card Density and used an edge profile of Stroke.
(28nov19) Ryzen 1800x, 970 EVO 1TB M.2 SSD, Corsair Vengeance 64GB DDR4 3200 Mem,  EVGA GeForce GTX 1080 Ti FTW3 Graphics 441.41 (27nov19), Win 10 Pro x64, Terragen Pro 4.4.45, BenchMark 0:10:02

WAS

June 29, 2018, 03:38:38 pm #9 Last Edit: June 29, 2018, 03:47:00 pm by WASasquatch
Seems the problem has nothing to do with the shader, but in fact the card object. Scaling it breaks opacity for some reason (should be able to scale a card to correct proportions for your scenes) it seems. I setup your card pop with my original scales for flame licks for small scale, and boom, back to black waves.

Edit: Actually, your base file (no edits) has the same black marks, see second image o.O Now I"m just confused.

I do feel a surface layer and glass shader after the default shader where opacity is happening would only serve to cause more issues, but it doesn't seem to make any difference (on my end).
Check out the Terragen Community on Facebook: https://www.facebook.com/groups/Terragen.Galleries/

Matt

Partial opacity does not work properly yet. You'll need to create transparency using a Glass Shader and then merge it with (or follow it by) your shader. Some ideas here: https://planetside.co.uk/forums/index.php/topic,24648.0.html
Just because milk is white doesn't mean that clouds are made of milk.

WAS

June 29, 2018, 05:56:28 pm #11 Last Edit: June 29, 2018, 05:58:17 pm by WASasquatch
Quote from: Matt on June 29, 2018, 04:08:52 pm
Partial opacity does not work properly yet. You'll need to create transparency using a Glass Shader and then merge it with (or follow it by) your shader. Some ideas here: https://planetside.co.uk/forums/index.php/topic,24648.0.html


This doesn't even need to be gradual transparency as luminosity does the rest, and flames don't have gradual transparency at their boundaries usually. The flames, such as in the first image work rather well besides being sliced off. The issue seems to be creating their max height with surface layers and the colour provided by them working with opacity. Though there are some weird black issues in the flames but that seemed to be remedied when adjust the colour for the flames in other tests.
Check out the Terragen Community on Facebook: https://www.facebook.com/groups/Terragen.Galleries/

jaf

Are you sure you get the black marks when rendering 2D Flame Card Pop-try3.tgd without editing it?  I just tried it again and didn't get the black marking.

I know the shape of the flames is not that great on my file, but was thinking it could be combined with yours to get you closer to what you're looking for.
(28nov19) Ryzen 1800x, 970 EVO 1TB M.2 SSD, Corsair Vengeance 64GB DDR4 3200 Mem,  EVGA GeForce GTX 1080 Ti FTW3 Graphics 441.41 (27nov19), Win 10 Pro x64, Terragen Pro 4.4.45, BenchMark 0:10:02

WAS

Yeah I tried simply opened the file from forums, no downloading (open as option) to TG folder where my edited version was, and hit render. So it was exact file you had setup opening from my temp files from Firefox.
Check out the Terragen Community on Facebook: https://www.facebook.com/groups/Terragen.Galleries/

WAS

Here's a video straight from thread. So if there is differences between systems, sounds like a bug with TG.

Edit: Going to have to upload elsewhere... It's only 4,800~kb but the forum thinks it's over 5,000kb.  Lol

https://drive.google.com/open?id=1xvr5N-8odFouCe7i2aB1WGRasPSub0ib
Check out the Terragen Community on Facebook: https://www.facebook.com/groups/Terragen.Galleries/