Black objects

Started by xsimekp1, July 22, 2018, 06:06:54 pm

Previous topic - Next topic


July 22, 2018, 06:06:54 pm Last Edit: July 22, 2018, 06:09:46 pm by xsimekp1
Hi Terragen masters,

we just bought for our projects Full terragen version, it looks nice. I am quite newbie in it, as i am more 3d graphic (3ds max)
I have got problem with rendering distrbuted objects, they are all black, you can see , that the textures are somehow loaded (object from

Any suggestions please? The documentation for the program is real pain, nothing helped.

Pavel (Prague, Czech republic)


Quick fix?

Sun position is behind objects, 360, look at shadows

Fix Sun 180 to face object , look at shadows

The same scene, just changed the sun position  :)


Thx, but it did not helped


Are you getting error messages about texture path?


No, you can see it in preview, that the textures are somehow loaded correctly, but i do not see them in preview nor render


Is the diffuse color at least a medium gray, if using image textures? Check opacity as well, probably needs white.


Yes it is, it is grey, opacity is also set to white


July 22, 2018, 07:27:31 pm #7 Last Edit: July 22, 2018, 07:30:25 pm by luvsmuzik
Save, close, reopen, re render....? Try UNSELECT RTP also...maybe


July 23, 2018, 01:20:14 am #8 Last Edit: July 23, 2018, 01:22:16 am by Dune
Welcome to this forum, Pavel. All begin is hard, but you'll find the community here very helpful. We very much welcome any renders you make, whether for asking questions or showing finished products or WIP's.
Regarding the black objects. Texture files are not well loaded  in every object (depends on the object), so you have to check certain things inside the object. There's a part node which contains one or more default shaders. In these you have to reassign the proper texture files.
After assigning inside textures and additional shaders (you can do a lot inside any object), it's wise to save that object as .tgo for future use. Though not every XFrog object can be saved as such, I have to add.


Thx For welcoming,

I tried restart, reopen. Nothing happened.
The textures are loaded somehow, thats why i uploaded the preview, you can see it on model on left side. Any other suggestions?


July 23, 2018, 03:28:42 am #10 Last Edit: July 23, 2018, 03:30:47 am by René
Can you see the textures in the preview? If you don't, they are not loaded(properly) and you have to load them manually.


Welcome to the forum, Pavel!!
You may have overlooked it in these examples here, but make the diffuse color where your texture is loaded white instead of grey. This might make your textures more visible.


You could also bypass the image texture, deleting it from diffuse image source, not the obj. file (keep the opacity mask). Use a bright green diffuse. Normals maybe messed up?
I don't remember if that palm is 3D or 2D.


Ok i tried everything above, nothing worked :/


July 23, 2018, 01:13:09 pm #14 Last Edit: July 23, 2018, 01:16:14 pm by luvsmuzik
I ask you to try another object in a population. Double double check your image map path, make sure it is to your render computer, not the generic texture path.

For texture to show in must be in RENDERS preview.