Planetside Software Forums

General => Terragen Discussion => Topic started by: xsimekp1 on July 22, 2018, 06:06:54 pm

Title: Black objects
Post by: xsimekp1 on July 22, 2018, 06:06:54 pm
Hi Terragen masters,

we just bought for our projects Full terragen version, it looks nice. I am quite newbie in it, as i am more 3d graphic (3ds max)
I have got problem with rendering distrbuted objects, they are all black, you can see , that the textures are somehow loaded (object from xfrog.com)

Any suggestions please? The documentation for the program is real pain, nothing helped.

Pavel (Prague, Czech republic)
Title: Re: Black objects
Post by: luvsmuzik on July 22, 2018, 06:39:31 pm
Quick fix?

Sun position is behind objects, 360, look at shadows

Fix Sun 180 to face object , look at shadows

The same scene, just changed the sun position  :)
Title: Re: Black objects
Post by: xsimekp1 on July 22, 2018, 06:52:54 pm
Thx, but it did not helped


Title: Re: Black objects
Post by: luvsmuzik on July 22, 2018, 07:05:24 pm
Are you getting error messages about texture path?
Title: Re: Black objects
Post by: xsimekp1 on July 22, 2018, 07:08:42 pm
No, you can see it in preview, that the textures are somehow loaded correctly, but i do not see them in preview nor render
Title: Re: Black objects
Post by: luvsmuzik on July 22, 2018, 07:13:02 pm
Is the diffuse color at least a medium gray, if using image textures? Check opacity as well, probably needs white.
Title: Re: Black objects
Post by: xsimekp1 on July 22, 2018, 07:22:54 pm
Yes it is, it is grey, opacity is also set to white
Title: Re: Black objects
Post by: luvsmuzik on July 22, 2018, 07:27:31 pm
Save, close, reopen, re render....? Try UNSELECT RTP also...maybe
Title: Re: Black objects
Post by: Dune on July 23, 2018, 01:20:14 am
Welcome to this forum, Pavel. All begin is hard, but you'll find the community here very helpful. We very much welcome any renders you make, whether for asking questions or showing finished products or WIP's.
Regarding the black objects. Texture files are not well loaded  in every object (depends on the object), so you have to check certain things inside the object. There's a part node which contains one or more default shaders. In these you have to reassign the proper texture files.
After assigning inside textures and additional shaders (you can do a lot inside any object), it's wise to save that object as .tgo for future use. Though not every XFrog object can be saved as such, I have to add.
Title: Re: Black objects
Post by: xsimekp1 on July 23, 2018, 02:42:38 am
Thx For welcoming,

I tried restart, reopen. Nothing happened.
The textures are loaded somehow, thats why i uploaded the preview, you can see it on model on left side. Any other suggestions?
Thx
P..
Title: Re: Black objects
Post by: René on July 23, 2018, 03:28:42 am
Can you see the textures in the preview? If you don't, they are not loaded(properly) and you have to load them manually.
Title: Re: Black objects
Post by: Hannes on July 23, 2018, 11:40:29 am
Welcome to the forum, Pavel!!
You may have overlooked it in these examples here, but make the diffuse color where your texture is loaded white instead of grey. This might make your textures more visible.
Title: Re: Black objects
Post by: luvsmuzik on July 23, 2018, 11:52:49 am
You could also bypass the image texture, deleting it from diffuse image source, not the obj. file (keep the opacity mask). Use a bright green diffuse. Normals maybe messed up?
I don't remember if that palm is 3D or 2D.
Title: Re: Black objects
Post by: xsimekp1 on July 23, 2018, 12:49:50 pm
Ok i tried everything above, nothing worked :/
Title: Re: Black objects
Post by: luvsmuzik on July 23, 2018, 01:13:09 pm
I ask you to try another object in a population. Double double check your image map path, make sure it is to your render computer, not the generic texture path.

For texture to show in preview.....you must be in RENDERS preview.
Title: Re: Black objects
Post by: Matt on July 23, 2018, 01:18:05 pm
Hi Pavel,

In your last screenshot, you would need to enable the Shaders button (the green sphere) next to the RTP button. It remembers these settings separately for each UI Layout, so when you switched the Objects layout it was turned off.

The next thing I would suggest is to increase exposure in the preview, just to make sure that the textures really are black, not just very dark. To open the exposure control, there's a square icon at the bottom left of the preview with a black-and-white "+/-" icon. Or there are many other ways you could brighten the objects, such as increasing the sunlight intensity or setting the diffuse colour higher than 1.

If the objects really are completely black in the preview, it might be that the surface normals are not being loaded the way Terragen expects them. But, as this is an Xfrog object, I don't think this is likely to be the cause.

Something else to bear in mind is that the RTP does not always update materials and objects - sometimes it needs to be encouraged to update by disabling RTP and then re-enabling.

Matt
Title: Re: Black objects
Post by: Matt on July 23, 2018, 01:20:40 pm
Also, try doing a render, if you haven't already.
Title: Re: Black objects
Post by: xsimekp1 on July 23, 2018, 02:42:39 pm
it works with another trees :/ so i just have to find proper model, thx a lot guys
Title: Re: Black objects
Post by: luvsmuzik on July 23, 2018, 02:55:46 pm
For the heck of it Flip Normals on Queen Palm. Just add it as 1 object.
Title: Re: Black objects
Post by: Dune on July 24, 2018, 02:46:56 am
.
Title: Re: Black objects
Post by: WASasquatch on November 19, 2018, 11:55:27 pm
I'm curious what may be causing this too. Here is a simple object I was modeling trying to learn some things, I set the colour in the modeling program, and it carries over to TG, but they object is black?
Title: Re: Black objects
Post by: Dune on November 20, 2018, 01:44:05 am
I can't open a rar on this machine, but I suspect it either having no normals or something else went wrong, so I'd always take it through Poseray and recalculate the normals.
Title: Re: Black objects
Post by: WASasquatch on November 20, 2018, 04:37:36 pm
Quote from: Dune on November 20, 2018, 01:44:05 am
I can't open a rar on this machine, but I suspect it either having no normals or something else went wrong, so I'd always take it through Poseray and recalculate the normals.


Of course. Thanks Ulco.

They're nothing worth downloading anyway haha. Just playing with ngPlant

It has potential if I can track down some nice textures and leaf textures (or make them). It's a little limited and quirky.
Title: Re: Black objects
Post by: bobbystahr on November 23, 2018, 10:01:27 am
Odd that, I've used that free Queen Palm in all it's ages and it loads perfectly.
Title: Re: Black objects
Post by: sboerner on November 23, 2018, 12:26:35 pm
Hi Pavel -

Yes, welcome to the forum! Did you happen to save the original .tgd file that you were having problems with? If so can you post it here? No need to include the Xfrog tree model, I have that. I'm just curious . . . no reason why that shouldn't be working for you.

Steve
Title: Re: Black objects
Post by: surrealdan on November 29, 2018, 09:55:52 am
I've had this problem before, took me a while to figure out. Make sure your maps are applied, and increase the diffuse amount to 1, then in the colour of the pop object increase the diffuse multiplier by 1.5 or 2, increase gradually and check your renders, I would also check if there's a translucency map to help light bleed through the leafs. That method has worked for me!
Title: Re: Black objects
Post by: lat 64 on February 17, 2019, 06:45:22 pm
I was having this same blackout problem today until I found this thread. Groked. ??? My own solution was to delete the surface Parts shader that TG assigned to my .OBJ and just make a new one Surface shader. It worked! Hope that helps someone.

See attached for a shot of what melts out of glaciers these days here in Alaska. Evidence of oxide deposits at the crash site indicates some attempt at a restart and takeoff was tried but not successful. Estimated age of craft is about 3,000 years old.

What, no triple-A? Must have been out of cell phone rage :o.
Title: Re: Black objects
Post by: bobbystahr on February 17, 2019, 08:32:58 pm
great image lat 64..I find having a back story makes some images even better....
Title: Re: Black objects
Post by: Dune on February 18, 2019, 01:39:48 am
 ;D Nice one!
Title: Re: Black objects
Post by: lat 64 on February 18, 2019, 12:20:18 pm
Something seems to be wrong with the Parts Shader on this X-wing. I Did some more experimenting with a new copy of the same Object and it is a repeatable offense. It happens each time. I corrected my earlier post for accuracy. I could not get it to "color" until I just broke the connection to the Parts Shader and created a Surface shader in it's place. This was patch but not a solution for the best modeling.

Oh well. I'm just fooling around and trying to figure stuff out.

Title: Re: Black objects
Post by: bobbystahr on February 18, 2019, 12:36:11 pm
Quote from: lat 64 on February 18, 2019, 12:20:18 pm
Something seems to be wrong with the Parts Shader on this X-wing. I Did some more experimenting with a new copy of the same Object and it is a repeatable offense. It happens each time. I corrected my earlier post for accuracy. I could not get it to "color" until I just broke the connection to the Parts Shader and created a Surface shader in it's place. This was patch but not a solution for the best modeling.

Oh well. I'm just fooling around and trying to figure stuff out.




Can you share the model?...I have had some luck correcting models
Title: Re: Black objects
Post by: lat 64 on February 18, 2019, 04:52:09 pm
Sure, It's a simple model exported from an STL to .obj, so it never had more than one shader.
Should I post it on the file sharing topics section?
Title: Re: Black objects
Post by: bobbystahr on February 18, 2019, 05:36:18 pm
Quote from: lat 64 on February 18, 2019, 04:52:09 pm
Sure, It's a simple model exported from an STL to .obj, so it never had more than one shader.
Should I post it on the file sharing topics section?


sounds good