Author Topic: Bug: Removing keyframes crashes TG  (Read 204 times)

Offline DutchDimension

  • Member
  • *
  • Posts: 57
  • Environment Artist @ Square Enix
Bug: Removing keyframes crashes TG
« on: August 23, 2018, 03:32:54 AM »
Try this,

  • Start a new default TG scene.
  • Add an Easy Cloud node.
  • At frame 1, set a keyframe on the Easy Cloud 01 'Coverage' parameter.
  • Set the timeline to 100, change the 'Coverage' parameter to some other value and lock it in with another keyframe.
  • Go back to frame 1 and remove the first keyframe by using the  function/Animation button to the left of the parameter.
  • Go to frame 100 and remove the second keyframe in the same way.

For me, this causes TG to crash instantly and is 100% reproducible.
This is on TG build 4.1.18 on Windows 7 Enterprise SP1

The workaround appears to be to delete the keyframes inside the Animation Panel.
« Last Edit: August 23, 2018, 03:47:56 AM by DutchDimension »

Offline Matt

  • Planetside Staff
  • *
  • Posts: 3578
  • I'm the crazy one
Re: Bug: Removing keyframes crashes TG
« Reply #1 on: August 23, 2018, 11:20:38 AM »
Confirmed. I can also reproduce it by simply creating one key frame and then using Delete Animation. I'm working on a fix now.
Just because milk is white doesn't mean that clouds are made of milk.

Offline DutchDimension

  • Member
  • *
  • Posts: 57
  • Environment Artist @ Square Enix
Re: Bug: Removing keyframes crashes TG
« Reply #2 on: August 23, 2018, 02:32:23 PM »
Thanks Matt!