Bug: Removing keyframes crashes TG

Started by DutchDimension, August 22, 2018, 11:32:54 pm

Previous topic - Next topic

DutchDimension

August 22, 2018, 11:32:54 pm Last Edit: August 22, 2018, 11:47:56 pm by DutchDimension
Try this,


  • Start a new default TG scene.

  • Add an Easy Cloud node.

  • At frame 1, set a keyframe on the Easy Cloud 01 'Coverage' parameter.

  • Set the timeline to 100, change the 'Coverage' parameter to some other value and lock it in with another keyframe.

  • Go back to frame 1 and remove the first keyframe by using the  function/Animation button to the left of the parameter.

  • Go to frame 100 and remove the second keyframe in the same way.



For me, this causes TG to crash instantly and is 100% reproducible.
This is on TG build 4.1.18 on Windows 7 Enterprise SP1

The workaround appears to be to delete the keyframes inside the Animation Panel.

Matt

Confirmed. I can also reproduce it by simply creating one key frame and then using Delete Animation. I'm working on a fix now.
Just because milk is white doesn't mean that clouds are made of milk.

DutchDimension