c0000005 crashes

Started by narvik, October 22, 2007, 09:10:31 am

Previous topic - Next topic

narvik

Okay, thanks bigben.

Is there a way to convert the heightfield to a TER then?

narvik

By the way, there is something strange going on when executing the command line:
I do see several lines that contain the word "cannot"....it may or may not have to do with the heighfield - unfortunately I can't
read what it says as the command prompt only displays maybe a 100 lines and the "cannot whatever" lines get pushed up so far they get deleted...

Anyway to capture the full text of the command promt?

Oshyan

Heightfield auto-generate is currently buggy and is not recommended. However once you generate your heightfield manually in the GUI you can just right-click the Heightfield Generate node and choose Save File As and give it a name and location (be sure to put .ter on the end). Then you can replace the Generate with a Heightfield Load node and it should work in commandline setups.

- Oshyan

narvik

October 25, 2007, 02:09:37 pm #18 Last Edit: October 25, 2007, 02:20:30 pm by narvik
Thanks Oshyan,
another questions though; how do you call a Heightfield Load node in the command line?

EDIT: oh, sorry, I know what you mean now.....will try that.

narvik

SUCCESS!  ;D ;D ;D

I was able to render a complete frame using the command line!

Many thanks to all who helped; Oshyan, bigben, and you-know-who.

Now final step would be to write a batch file that keeps on executing the command line, with a new frame number.
If anyone knows how to do that, I'd appreciate some help there.

Maybe split the batch process up into 12 batches or so?

This frame took about 4hrs+ to render, and there's about 1400 frames left.

bigben

You could try my script tool (linked in previous reply) or use a spread sheet and text editor.
1: In the spreadsheet you need 3 columns...
  column 1, text before the frame number (copy to first row and fill down)
  column 2, sequential frame number

2: save as text
3: open in text editor and remove tabs (don't forget to include a space at the end of the text in column 1).

narvik

bigben,
thanks for the reply.

I'm still not quite understanding that though.


If I have a text file that looks like this:

=========================================
Set TERRAGEN_PATH=C:\T            
            
%TERRAGEN_PATH%\tgdcli.exe -p C:\T\P.tgd -r -f 266
%TERRAGEN_PATH%\tgdcli.exe -p C:\T\P.tgd -r -f 267
%TERRAGEN_PATH%\tgdcli.exe -p C:\T\P.tgd -r -f 268
%TERRAGEN_PATH%\tgdcli.exe -p C:\T\P.tgd -r -f 269
%TERRAGEN_PATH%\tgdcli.exe -p C:\T\P.tgd -r -f 270
%TERRAGEN_PATH%\tgdcli.exe -p C:\T\P.tgd -r -f 271
%TERRAGEN_PATH%\tgdcli.exe -p C:\T\P.tgd -r -f 272
%TERRAGEN_PATH%\tgdcli.exe -p C:\T\P.tgd -r -f 273
etc
==========================================

How do I run that in the command line so that the computer renders all the frames?




bigben

Change the file extension from .txt to .bat and double click  ;)

narvik

Quote from: bigben on October 26, 2007, 09:19:06 pm
Change the file extension from .txt to .bat and double click  ;)


Oh, hahaha! That I can manage...   :D :D

Thanks bigben...

narvik

Okay, this is now [almnost] working perfectly.

Now I am getting my brain wrapped around TG2, I'm starting to like it a lot.


Two things though:

1)
When is next update coming out approximately, and what will be added/fixed?

2)
I am getting a few errors when executing the BAT file; namely:
ERROR: DeclareParam: Cannot declare more than 256 parameters!

These are assumably after 256 of them? I get quite a few of these errors; they are called something like:
AddClass: added class square_root_colour (numbers....)
AddClass: added class perlin 3D scaler (numbers....)
AddClass: added class square_colour (numbers....)
etc

The pic looks to be fine (except for some lingering WHITE SPOTS still...); but I was wonderiong what effect these errors have on the animation?



Oshyan

The next update will probably be the final release and there will be some significant improvements in rendering, UI, etc.

I haven't seen that error before. Since you're rendering from the commandline in a batch file and this is a fairly unusual circumstance I would tend to assume that is the source of the problem. Perhaps your batch execution lines are not being properly parsed as individual, sequential commands, but rather as continuous lines, causing an overflow of the command stack?

- Oshyan

bigben

Possibly long filenames creating a very long command string?

Only guessing though.  For rendering animations I move the files to a folder almost directly off the root directory so that the path+filename is very short. I get pretty pedantic when it comes to setting up commandline stuff, but it seems to pay off. About the only "luxury" I allow myself is long filenames, apart from that I stick to old-school DOS file naming rules.

If it's and encoding issue as Oshyan suggested, this is easily fixed by opening the batch file in WordPad and saving it. This fixes incorrectly encoded EOL characters. I have had encoding issues but haven't seen this error yet myself, but as it's a simple check/fix it's worth a try.

narvik

November 09, 2007, 08:21:38 am #27 Last Edit: November 09, 2007, 09:14:29 am by narvik
***** UPDATE *****
These ERRORS are now eliminated. There was an issue with FOLDER locations, that made something go wonky.
Not sure exactly what, but it seemed the Terragen program didn't like being in the same folder as the all the object and TGD files,
or something like that anyway....

***** END UPDATE *****



Thanks once more for the help...

I am not sure if this is really generated from the command line or not.
The good news is, that it DOES NOT CRASH AT ALL now. Totally rock solid, and it can render consecutive frames with VERY complicated populations.

For your viewing pleasure I've [screen]captured the command prompt several times and stitched them together as a GIF file.

If anyone can take a look at it and see what might be going on, that would be cool...

I'm not too tech savy, but I look for words like:
ERROR, and CANNOT, and FALSE, and my gut tells me that can't be too good!  ;)
...and there's plenty of those words here....   :-\

For instance, what is "False UCbool"?

Here's the pic....

Not sure how to make the image a clickable link, so here's the link to the image:
http://fjordland.com/batch_script_screen_capture.gif



***** UPDATE *****
These ERRORS are now eliminated. There was an issue with FOLDER locations, that made something go wonky.
Not sure exactly what, but it seemed the Terragen program didn't like being in the same folder as the all the object and TGD files,
or something like that anyway....

***** END UPDATE *****


jo

Hi,

Quote from: narvik on November 09, 2007, 08:21:38 am
For instance, what is "False UCbool"?


Nothing to worry about :-). It's something to do with parsing the preferences file and is just to let me know things were working correctly. I've taken this out now, it's been working correctly for ages.

I'm not sure what might have been causing the DeclareParam errors. I did actually have something like this the other day, but it was only because some code had changed and I hadn't completely rebuilt everything. Nothing to do with what was causing your problems.

Regards,

Jo

narvik

Sweet, thanks Jo.

---

Unfortunately still having white-spot issues....opened new thread for that.