Glass object highlights

Started by Hannes, October 25, 2019, 05:59:11 am

Previous topic - Next topic

Hannes

I'm trying to render an eye. There's an inner object with the textures and a slightly larger object with a bulged front to simulate the cornea with a glass shader assigned to it.
Of course this cornea shouldn't cast a shadow, but whenever I uncheck "cast shadows" of the object, I lose the highlight. Reflections are there. When I turn "cast shadows" on, the highlights are there, but it looks quite dark. No matter, if I render with the standard renderer or the path tracer.

Dune

Strange. And what if you do it all on one eyeball? In my geode I projected an image onto the front, which gave its SSS

Hannes

I want the eyeball look perfectly realistic including the crucial glassy cornea area. 
In my opinion the eyes sell the image.

I'm not sure, but I think I did that before, with the same setup, and had nice highlights with cast shadows disabled.

Dune

What if you open in an older version? If so, maybe it's a bug.

Hannes


Hannes

Ha! It seems to be a bug indeed. I opened the exact same file in TG 4.3.16, and then in the latest version. See attached image.

Hannes

One more self explanatory image.

KyL

Good catch!

And nice eye model too! Is the iris modeled?

Hannes

Thanks, KyL! The iris is squashed in, but mainly it's a texture.

bobbystahr

cool eye and good catch...noted...didja file a bug report?
something borrowed,
something Blue.
Ring out the Old.
Bring in the New
Bobby Stahr, Paracosmologist

Hannes

Thanks!!! Not yet, but I guess, Matt or Oshyan will read that.

Oshyan

Thanks for the report. We're on it!

- Oshyan

Hannes

Cool! Thanks.
As far as I can tell by now, it's only happening with the glass- and the water shader. Even if you put a reflective shader with raytrace reflections off behind the glass shader, there are no highlights, when the object is set to not cast shadows.
If you have a surface layer for example with a reflective shader afterwards, highlights are there.