Object interiors illuminated with 4.4.46 frontier

Started by sboerner, December 13, 2019, 03:42:05 pm

Previous topic - Next topic

sboerner

Just noticed that the interior surfaces of objects (such as buildings) are illuminated now when they are rendered with the path tracer in 4.4.46 frontier. Don't recall ever seeing this with the path tracer. A couple of comparisons:

Oshyan

Strange. I was going to ask if there were glass materials involved, but in the case of the barn door I wouldn't think so! Are you using Exaggerate Surface Details? Maybe Matt has some other ideas...

- Oshyan

sboerner

Exaggerate Surface Details is disabled. The house has glass in the windows with transparency set to 0.4, so the interior surfaces probably would be brighter without them. (My first thought was the glass was the culprit, too, but then I saw the barn).

Oshyan

Hmm. Matt may not be able to respond for a few days and I don't have any other ideas off-hand. In these cases I often end up just trying different things until the problem resolves and then hopefully I can figure out what did it. :D So if you can share the model and simple TGD setup I can put that into my test backlog and hopefully have an answer for you some time soon.

- Oshyan

sboerner

Thanks. Can I email it to you at Terragen support?

There's no problem as I can just use 4.4.45.

Oshyan

Of course, you can always email us there. :)

You are saying it definitely doesn't happen in 4.4.45 but does in 4.4.46? If so it should be reasonably easy to find the cause of the problem. But example files are still helpful.

- Oshyan

Dune

Weird indeed, and that was just one of the strengths of PT, getting dark interiors! I will check out some of mine too.

Dune

I don't see a difference between 4.4.36 and 4.4.46, but I do see a difference between defered rendering and PT, which strikes me.

sboerner

QuoteI don't see a difference between 4.4.36 and 4.4.46, but I do see a difference between defered rendering and PT, which strikes me.
Do you mean using the standard renderer with defer atmo/cloud and all shading enabled? I'll have to try that.


I seem to have narrowed it down a bit. It only seems to happen when a bump is applied to the surface, and only with 4.4.46. It happens with both the standard and path traced renderers, though it's more noticeable with the path tracer because (as Ulco mentioned) that normally renders more naturally dark interiors.

Sample renderings attached plus the test file. (Maybe I'm missing something.)

I also tested it in 4.4.44, which behaves the same way as 4.4.45. I don't have any earlier versions installed.

Oshyan

Thanks for doing further testing. There were some changes to bump handling in 4.4.46, so an error may have crept in. I've sent your files to Matt for analysis.

- Oshyan

Dune


Matt

This is fixed in 4.4.48 (Frontier Build). I needed to make some changes to the renderer which could possibly affect other types of illumination, but it seems to be correct in the tests I've run. 4.4.48 is available today on Windows and Linux (Check for Updates), but the Mac version hasn't been updated yet.
Just because milk is white doesn't mean that clouds are made of milk.

Dune


KyL

I just encountered this issue on a few assets this week. 4.4.48 does fix it, thanks!

sboerner