Bucket render artifacts on plane only with PT

Started by Hannes, February 18, 2020, 06:35:16 am

Previous topic - Next topic

Hannes

February 18, 2020, 06:35:16 am Last Edit: February 18, 2020, 07:51:43 am by Hannes
I have a scene that's completely lit only by a white self illuminating plane to create a soft light.
In the background I have another plane with an image map of a cloudy sky assigned to. The atmosphere is completely disabled in this scene, which cuts rendertimes quite a lot.

Whenever I render the scene with the pathtracer I get weird render artifacts on the background plane (see image below). It renders correctly with the legacy sampler! (Edit: I mean the renderer!!!)
I tried a lot of things like using an imported plane object instead of the internal one, using the color image input i. e. the luminosity image input of the default shader instead of an image map shader, disabling visible to other rays, changing the render method, also created a GI cache file, but nothing helped.

Any ideas? I attached the reduced scene, so that you may test it.

Tangled-Universe

You mean the legacy sampler version is also a path traced render?

The path tracer does not use the GI cache for surfaces, only for atmosphere GI on surfaces, but usually these are quite diffuse and thus you don't need a very detailed GI cache.

If it's indeed path tracer + legacy and not rendering correctly with the path tracer + adaptive sampler then it's probably a simple bug where the adaptive sampler is not dealing well with a (rather unusual) situation like this.

Neat trick though!

Hannes

Quote from: Tangled-Universe on February 18, 2020, 07:44:56 amYou mean the legacy sampler version is also a path traced render?
Oops, I used the wrong term. It's the legacy renderer! One is rendered with the path tracer, the other is not. Otherwise there are no changes.

I edited my first post.

Matt

February 18, 2020, 07:01:54 pm #3 Last Edit: February 18, 2020, 07:05:31 pm by Matt
It's a problem with the camera projection mode on the image map shader. In the standard renderer this works without a camera assigned to it, but in current builds you'll need to assign a camera when using it with the path tracer. The projection has different properties when assigning a camera, so you will probably need to adjust the Y scaling.

It's a good idea to assign a camera anyway, otherwise reflections may not be correct even in the standard renderer.
Just because milk is white doesn't mean that clouds are made of milk.

Hannes

Thanks, Matt! I just saw, that there's no camera assigned to the image map shader in the file I attached. I must have forgotten it. Embarrassing, since I know that!  :-[ I tested my file with a camera assigned, and the bucket artifacts were gone.
But at the moment I'm rendering my original scene, and the camera is assigned to the shader (see image below). The problem is still there.

I even copied the card object from the scene I attached here (which looked correct after I assigned the camera) and pasted it into my original scene insted of the imported plane, and the artifacts are still there! So, could this be a memory issue? There are many object populations and detailed objects in the scene, but I have 32 GB of RAM. Weird... :(

Matt

Just because milk is white doesn't mean that clouds are made of milk.

Hannes

Well, this is going to be a big one!! Essentially the already attached scene is the original scene, only without all the objects, shaders and terrain.
But since it's maybe a memory issue I'll gather the scene and send you the link in a pm, OK?

Hannes

Just sent you the file per e-mail (WeTransfer), Matt.
Thanks in advance!

Matt

Thanks Hannes, got it.

In your new file the Plane.obj has some diffuse colour, and that seems to be what's causing the blocky shading. I don't know why it's not just rendering with a consistent shade, and it looks like there might be a bug. But if you make it luminous only it seems to render without problems.
Just because milk is white doesn't mean that clouds are made of milk.

Hannes

Wow, that was fast! Thanks a lot, Matt. I'll test it immediately. And yet it's still weird, that it rendered correctly in my reduced file, when the camera was assigned to the image map shader.

Hannes

Just tested it. I disconnected the image map shader from the color function input of the shader, and made it black, so only the luminosity was active. Works like a charm :) , and there is something else: while TG took quite a long time (almost five minutes) to render a very small part of the cloud plane when the color function input was fed with the image map shader, it now renders within a few seconds! A bug for sure, I'd say.

Matt

I noticed that the Background node is still enabled and it hasn't got a camera assigned to it. It's casting light into the scene, but without the camera assigned it's falling foul of that bug. It's illuminating the Plane.obj with its light and the light is changing from bucket to bucket.
Just because milk is white doesn't mean that clouds are made of milk.

Hannes

Where's the head slapping smiley? :-[ :-[ :-[
First I tried to use the background object for the cloud image, but it didn't look good, so I used a plane and forgot to disable the background...

Hannes


Matt

Easily done. But you can blame it on the bug, without which none of this would have happened!
Just because milk is white doesn't mean that clouds are made of milk.