preview differs from render

Started by Dune, February 22, 2020, 02:18:24 am

Previous topic - Next topic

Dune

Here's another mystery. I need to make a 8x1m panorama of a streetscene, and need to do it in 2 frames/renders, second frame 45ยบ rotated. So I set up 4:1 render ratio, checked preview (looked okay), and rendered. But the outcome is quite different. Here's a simple testfile. If anyone can explain, I'd be much obliged. It probably has to do with vfov and hfov, and I have done something similar years ago with the huge museum file (85x3m) (also using PTGUI in some way, which provided me with pixelperfect fitting of frames), but can't figure out what I'm doing wrong.

cyphyr

February 22, 2020, 05:30:25 am #1 Last Edit: February 22, 2020, 05:33:43 am by cyphyr
Turn off Motion blur and set to 0 in camera .

This one has got me a few times in the past.

Motion Blur on.jpgMotion Blur off.jpg
www.richardfraser.co.uk
https://www.facebook.com/RichardFraserVFX/
/|\

Ryzen 9 3900X @3.79Ghz, 64Gb (TG4 benchmark 6:20)
i7 5930K @3.5Ghz, 32Gb (TG4 benchmark 13.44)

Dune

Thanks Richard. I did turn of motion blur, but didn't change the 0.5. Strange actually, that it works that way.

Kadri

This comes up all the time. I think Matt will say "what the heck" and will change it at last ;D

Dune

Shouldn't be too hard, I think; when motion blur is unchecked set default value to 0.



Dune

I'm just a bit slow :P  Unlogical stuff don't linger ;)


WAS

I like that idea though.

Quote from: Oshyan 21/06/2015, 14:26:29Some kind of warning when blur is disabled that "blur length is non-zero" (pop-up?) might be a way to mitigate this.

Dune

I added a feature request in the project tracker to have this warning popup (or something similar).

Hannes

For now we can just create a modified default scene with camera blur set to 0 and motion blur disabled:
https://planetside.co.uk/forums/index.php/topic,24478.msg248669.html#msg248669

Matt

I've changed how this works for v4.5 (coming soon).

Terragen 4.5+: When the motion blur checkbox is off, the image is rendered as though motion blur length and shutter offset are 0 so that it renders exactly on the camera values for that frame without any interpolation. This change also causes the motion vector render elements (tgSurf2dMotion and tgCloud2dMotion) to be empty/black when motion blur is turned off. To output motion vectors and get the same results as in v4.4, you now need to enable motion blur and set the motion blur method to "Vectors only, for post".
Just because milk is white doesn't mean that clouds are made of milk.

Kadri

February 23, 2020, 09:51:37 pm #13 Last Edit: February 24, 2020, 06:51:51 am by Kadri

Nice to hear Matt. But isn't there a possibility that the problem is now on the side who wants to use those features (tgSurf2dMotion and tgCloud2dMotion)? 
At least there will be less users affected maybe i don't know. Will be there a warning popup or something similar? Just curious.

Dune

Thanks, Matt! Though Kadri has a point, a small line with the motion blur checkbox may do.