Help with object populations

Started by jockc, April 18, 2009, 02:25:32 am

Previous topic - Next topic

jockc

Complete noob here.  I am playing with populations (clumps of grass, rocks) but I can't figure out how to change the color of the objects.  They always wind up being white.  I have tried adding surface shaders to the object but it doesn't work.  Also I can't see any way to control where the objects are placed. i.e. no slope/elev limits or anything like that.

gregsandor

How did you try to add surface shaders to the object?

jockc

Yes, I figured that part out.  Here is what I do:

Add Object -> Population -> Rock

under Distribution set area length and width to like 10000;  drag the area so the camera scene is covered; object spacing to about 50
under object Scale set the min and max scale to like 10 and 20
under Surface Shaders -> goto Default shader 01 and set diffuse color

at this point I have the object uniformly spread thru the scene and with the selected color.

But I want to control the distribution a little better.  For example I want to Limit the altitude and slope.

aymenk2003

Le peu que je sais, c'est à mon ignorance que je le dois.

jockc

I still can't get it to work.  Here are a few screen shots of showing what is happening.  I am using a 'grass' shader with test color set to bright red.  The camera is set to look from above.  I turn on display preview and you can see the distribution is not limited to the red area, which is what I expected.


cyphyr

Try setting your distribution shader to black and white, with the same settings as your Grass_Land shader. White allows an effect, black denies the effect.
richard
www.richardfraser.co.uk
https://www.facebook.com/RichardFraserVFX/
/|\

Ryzen 9 3900X @3.79Ghz, 64Gb (TG4 benchmark 6:20)
i7 5930K @3.5Ghz, 32Gb (TG4 benchmark 13.44)

jockc

I don't know how to set the distribution shader to black and white, but I did discover that if I create a new distribution shader (same settings as Grass_Land) and disconnect it from the main node group, and then select it for the Pop density shader, it works as expected. 

neuspadrin

the object needs to share the same density shader as your surface shader, it can't use the surface shader as a density shader. so you can either a) duplicate the density shader and set them to different ones, or b) make them share the same density shader that the surface shader uses.