editing materials very very slow

Started by james adamson, August 16, 2020, 09:22:32 am

Previous topic - Next topic

james adamson

High all.
I have some models with quite a few texture layers assigned to each model.
This one I am looking at has 16 layers. It is unworkably slow to change any of the settings and I have no idea why. It is fine on single layer models.
It is frustrating as I decided to render my final models in TG because it is so amazing with instances and I would avoid the hassle of a exporting a TG mesh and all the layers etc etc  but it seems what I gain there I loose on the ability to interactively edit my materials.
Has anyone got any tips that may speed this up. I was thinking of baking all the textures to one layer but I would then loose flexibility.
Cheers.
James.

sboerner

That's frustrating. By texture layers, do you mean object parts? (I would call them shading groups, coming from Maya.)

What version of Terragen? Do you have RTP enabled while making changes? What happens if you close Terragen and start a new session?

16 is not very many. Have you tried editing one of your models in an otherwise empty default scene? Or try a low-poly model such as a soccer ball or simple sphere with the same number of object parts. To try to isolate the problem.

james adamson

Hey. 
Thanks for responding.
Yes I guess in Modo they are material groups. I am using TG4 full version. And I have tried from a new default scene.
I have not tried a low poly model with many textures.
The model itself is pretty complex. Its an Evermotion building and is extremely detailed inside and out so I wonder if thats the problem. Although its not the poly count itself causing the problems because Tg only really slows down when attempting to edit the materials when in the internal shader nodes of the obj. I have had RTP off.
Cheers.
James.

sboerner

Sometimes things slow down when I'm placing new objects in a big scene, but internal networks usually edit OK even with large models. Does the same thing happen with low-poly models?

Mac or PC?

I'm happy to take a look if you want to share the model via Dropbox or whatever.

Matt

Hi James. If you wouldn't mind sending these files to me (either my PM or at our support email) we'll try to figure out what's causing the slowdown.
Just because milk is white doesn't mean that clouds are made of milk.

james adamson

Great.
Will get those to you tomorrow.
Thanks.


Dune

First of all I always combine parts in Poseray that call the same material, so you end up with as little as possible parts. Then I always open an empty version of TG and just have the node window open, no preview. I noticed that preview on takes  a bit of memory and indeed sometimes slows down working on the parts and shaders.
When all is filled in, I check with crop renders, if things need to change, I click away the preview. Works fine for me.

jaf

Not sure if this helps, but I noticed if I have an object highlighted in the Objects tab and I'm editing materials for that object in the nodes, things are quite slow.  If I select some other object in the tab panel (like Planet 01), things are speedier back in the node edits.
(06Oct20) Ryzen 1800x, 970 EVO 1TB M.2 SSD, Corsair Vengeance 64GB DDR4 3200 Mem,  EVGA GeForce GTX 1080 Ti FTW3 Graphics 456.55 (06Oct20), Win 10 Pro x64, Terragen Pro 4.5.43 Frontier, BenchMark 0:10:02

james adamson

Thanks all. I will try the de select option.
And I did not think poseray was available for mac.

Dune

I don't know about that, but there might be other software that can combine mats/parts.

james adamson

Yes. Or maybe I go in a streamline the models' myself.
I have 108 of them so I was hoping to avoid that but that's the bottleneck that needs sorting right now.
Will explore the internet for such a software.
Cheers.
James.

james adamson

This is driving me nuts.
I have tried everything. I am in Terragen I have 56 gb of memory free yet editing materials is a nightmare. Every time I touch a slider I get the beachball gadget. I have simplified model as much as I can and removed some materials and have preview window
off. All have made zero difference. Weirdly I just loaded a setup and the sliders moved normally but soon reverted back to unhappy mode.
Any more ideas or suggestions would be great. 
Oh it happens on different models with different textures the only common thread is they are all Archmodels. I can also edit these materials with no problem in my 3d app.
Cheers.
James

luvsmuzik

Are your textures 4K or 8K png type? For some reason my TG slows down using png or 4K  It could be texture bake is needed or perhaps cached?

james adamson

Hi. It does not seem to discriminate! All shaders are slow to edit. 4k images down to 1024.
I have tried exporting out as a tgo to see if that sped things up but on reloading the tgo it said it could not find the images!
Arghhh!