Ray-Tracing...

Started by WAS, September 03, 2020, 12:55:20 am

Previous topic - Next topic

WAS

I also can't seem to Ray Trace previews in Terragen 4.5.38, it just finished immediately all black at 0.0s. :\

Dune

Even after you close the preview window and reopen it?

WAS

Yeah. I tried the X button, reset, and restarting TG. I hadn't noticed until now because I generally don't use it, but doing some fog under overcast, so I need both cloud layers to preview it so went to RTP.

This is what it looks like attached

Dune

Finished RTP in zero seconds, there must be something quite wrong. Can't help you with this.

Matt

September 03, 2020, 07:38:16 am #4 Last Edit: September 03, 2020, 07:41:47 am by Matt
Is anyone else having these problems with the RTP or memory use issues?

Considering there seem to be multiple issues with 4.5.38 on your machine, if it turns out they aren't reproducible on other computer it seems like there's something wrong with your installation of TG or the runtime libraries. Can you try doing a repair on the Microsoft C++ redistributables (a.k.a. runtimes)?

Another thing you could try is uninstalling the drivers for that input device which we were talking about in another thread which has been known to conflict with C++ runtimes.
Just because milk is white doesn't mean that clouds are made of milk.

Dune


WAS

I already repaired .NET and C++ runtimes to fix the Synapse problem, which has been solved. The mouse issue is related to when my second monitor (smart TV) is off, and for some reason Windows 10 sometimes doesn't except the termination signal and tries to connect to the monitor every 7 seconds exactly, causing the mouse to hiccup for whatever reason.

I also don't have any problems with any other software relying on C++ like Blender, ZBrush, Unreal Engine, or games like GTA.

The problem started with TG not detecting the runtimes already installed, trying to directly install over, creating a Installation Blocked error, and TG exiting. I then uninstalled the runtimes and let TG install them, which also for some reason reinstalled Visual Studio according to windows prompts with the Runtimes.

Uninstalling and Reinstalling Terragen doesn't have any issues detecting runtimes, and installs right away.

WAS

September 03, 2020, 02:28:30 pm #7 Last Edit: September 03, 2020, 02:35:46 pm by WAS
Reinstalling TG fixed the RTP, also from what I see. Works right away. Seems something installed wrong with TG itself.

Loading projects with null shaders within another shader still have all their settings unlinked (not sure why, xpaths can go super deep).

Rendering animation now for exhaustion prompts or my kernal tripped. Edit: I immediately see more physical RAM usage than virtual memory so that may be good.