Path Trace Reflection Roughness

Started by WAS, October 02, 2020, 12:26:31 pm

Previous topic - Next topic

WAS

October 02, 2020, 12:26:31 pm Last Edit: October 02, 2020, 12:34:03 pm by WAS
It's at 0, but I'm told to lower it for clear reflections? So does that really mean negative values? And to where? This slider has always been unforgiving and strange, and now things are weirder with two very different results between standard and path traced. There needs to be some uniformity here. It really should be just as reflective as Standard Renderer, making actual use of the roughness slider to obtain rough reflections like in Path Tracer. It was mentioned probably couple years ago that the value threshold would be fixed for Standard, too.

With how rough PT reflections are, that should be 1 on the roughness slider (of course allowing overhead for more blur).

cyphyr

Are you after a chrome/mirror reflection effect?
www.richardfraser.co.uk
https://www.facebook.com/RichardFraserVFX/
/|\

Ryzen 9 3900X @3.79Ghz, 64Gb (TG4 benchmark 6:20)
i7 5930K @3.5Ghz, 32Gb (TG4 benchmark 13.44)

WAS

Yeah, initially. Although I'm not sure what looks better. I'll have to post whenever I can get a PT finished. 12+ hours in and it's still working on my sphere I'm using as a surreal sci-fi ship. It does have sinus ripples on the top and bottom where I have "energy beams" as it's engine, so lots of lighting interaction, plus moody sky.

Blurry reflection kinda reminds me of a movie I saw recently I can't recall the name of where a sphere showed up that was reflective.

cyphyr

To get a reflective surface I set the reflection to 2 and the index of refraction to 4 (I have no idea why those numbers work, not logical I know but it looks ok) and of course the specular roughness set to 0.

I tried the set up with pt on and off and the results are pretty indistinguishable. It probably needs something more complex than a simple sphere for the pt to be that noticeable.

I guess your blurry reflections must be coming from another source, do you have any micro displacements creeping through? I have used micro displacement to simulate blurred reflections before it was a feature of the node.

reflective.JPG
www.richardfraser.co.uk
https://www.facebook.com/RichardFraserVFX/
/|\

Ryzen 9 3900X @3.79Ghz, 64Gb (TG4 benchmark 6:20)
i7 5930K @3.5Ghz, 32Gb (TG4 benchmark 13.44)

Matt

Quote from: cyphyr on October 02, 2020, 03:08:05 pmTo get a reflective surface I set the reflection to 2 and the index of refraction to 4 (I have no idea why those numbers work, not logical I know but it looks ok) and of course the specular roughness set to 0.

A more physically correct way to render metals in 4.5+ is with a Default Shader with the Metalness parameter set to 1. Then you don't need to cheat the max reflectivity or the IOR.
Just because milk is white doesn't mean that clouds are made of milk.

Matt

Are you using the Water Shader? You may need to change the minimum highlight spread, but I'm planning to fix that.
Just because milk is white doesn't mean that clouds are made of milk.

WAS

Reflective. I did Metalness but I switched as I wasn't sure if I was getting the right result in standard (probably settings though) so I just went to something familiar. This is the current settings.

The result it provides is totally blurry, where as standard render is a mirror and can see the clouds behind the camera, blue sky patches, etc nice and crisp.

I think I do like the blurriness, but maybe not so intense where the blue reflections are almost totally lost.

Matt

October 02, 2020, 04:56:13 pm #7 Last Edit: October 02, 2020, 05:00:11 pm by Matt
You have specular roughness at 0.1. The UI implies it only affects "highlights" but in the path tracer it affects all reflections (to be physically correct), and the UI hasn't caught up with that yet.

You need to reduce that to get a sharper reflection. You could set it to 0, but unfortunately that will reduce the highlight from the sun so you need to have something slightly greater than 0 (e.g. 0.001). I am thinking about adding a separate minimum spread for highlights which is independent of the main roughness parameter.
Just because milk is white doesn't mean that clouds are made of milk.

bobbystahr

Quote from: Matt on October 02, 2020, 04:06:44 pm
Quote from: cyphyr on October 02, 2020, 03:08:05 pmTo get a reflective surface I set the reflection to 2 and the index of refraction to 4 (I have no idea why those numbers work, not logical I know but it looks ok) and of course the specular roughness set to 0.

A more physically correct way to render metals in 4.5+ is with a Default Shader with the Metalness parameter set to 1. Then you don't need to cheat the max reflectivity or the IOR.

cool
something borrowed,
something Blue.
Ring out the Old.
Bring in the New
Bobby Stahr, Paracosmologist