Cloud "undo" bug?

Started by Kadri, February 24, 2021, 08:17:10 AM

Previous topic - Next topic


1) Make a new cloud node (i think it works with V2 and V3 the same).

2) Put a zero for example (works with any other number too i think) after the "cloud depth" of 500. Now undo this from 5000 to 500 again.

3) The cloud altitude and centre Y becomes 4000 instead of the initial 1750.

The interesting thing is this happens only when you change the cloud depth at first.
When you change the altitude or centre Y first and then change the cloud depth there is no problem with undo.

I use an old Terragen 64 bit v4.1.25 so not sure if this happens in the newer ones.
I saw something like this problem in the past but couldn't be sure until i tested it today more clearly.


Confirmed in newest build. Though I hardly ever use undo, but rather change variables.


Thanks Ulco. Yeah depends how you work for sure.
This problem actually happened more then ones to me and it was frustrating as i didn't know what happened,
when the cloud suddenly changed the appearance quite a lot.
I mostly loaded the last saved scene if i did not remember the numbers.


I remember something like this with the water plane too, where soimetimes if you do something with it, changing the water level did nothing, cause it wasn't changing the actual Y of the plane. Additionally, undoing settings would make the Y some random variable and often disappear from veiw. I found this out because Y wasn't changing so I hit Ctrl + Z and Y changed when water level reverted, but not representing the water level value.


I found the undo a bit prone to errors, sometimes even resulting in crashes or doing nothing. So I don't really use it.


Yes guys...there is one probably related to nodes when you unconnected them and undo doesn't connect them again when you try.
Not sure when and how that happens. Might try today for this maybe.

But in general undo is good for working.
Even for someone who used Lightwave for nearly 30 years without reasonable undo...doh!
Lightwave will go down as it looks without real undo :(


I tried the node not reconnecting undo bug and got it one time from many many attempts.
But can't reproduce it at will. Still not sure when it actually happens.