Visual C++ 2015-2019 Redistributable Runtime Libraries (x64) has failed to insta

Started by SuddenPlanet, March 15, 2021, 01:01:52 AM

Previous topic - Next topic

SuddenPlanet

How to get Terragen 4.5 Installed if you get this error?  I shouldn't have to uninstall newer versions of Visual C++ Runtimes.  Other programs need the newer versions, so...

Error:

QuoteComponent Visual C++ 2015-2019 Redistributable Runtime Libraries (x64) has failed to install with the following error message:
"Another version of this product is already installed. Installation of this version cannot continue. To configure or remove the existing version of this product, use Add/Remove Programs on the Control Panel. "

The following components failed to install:
- Visual C++ 2015-2019 Redistributable Runtime Libraries (x64)

WAS

Try uninstalling the version you have and let it install the version it needs. Hopefully doesn't conflict with other stuff you use.

SuddenPlanet

From looking at what I have installed now there is nothing newer, and I already have C++ 2015-2019 Installed which is what TG uses.

I think the TG Installer needs to be smarter, or needs a bypass C++ Runtime option.

WAS

Yeah, this is exactly what happened to me, there was no newer build, just older ones. I had a whole PC meltdown after letting the installation do it's thing, so many weird errors.

SuddenPlanet

OK, well I got TG 4.5 installed on two of my render nodes, but still stuck with 4.4.67 on my main Workstation.  Don't want to mess with VC++ stuff right now and mess something up.

Matt

Can you send us the complete log? At the moment it's not clear to me why the installer would try to install these runtimes when you already have a newer version installed, but the log might shed light on this.
Just because milk is white doesn't mean that clouds are made of milk.

SuddenPlanet

Quote from: Matt on March 16, 2021, 04:25:43 PMCan you send us the complete log? At the moment it's not clear to me why the installer would try to install these runtimes when you already have a newer version installed, but the log might shed light on this.

Where would the log you need get generated?  I'll look for it, and if it not there I can try installing again to see if the log gets generated.

Matt

Quote from: SuddenPlanet on March 17, 2021, 12:21:27 AMWhere would the log you need get generated?  I'll look for it, and if it not there I can try installing again to see if the log gets generated.

I think it gives you a link to the log if there is a problem. Unfortunately I don't remember where these logs are stored because I was following the links. If you don't mind, try installing again and look out for this link.
Just because milk is white doesn't mean that clouds are made of milk.

SuddenPlanet


SuddenPlanet

Just following up on this issue.  I did find a fix, and it was pretty easy.

All I had to do was go into the Windows Control Panel where you would normally Uninstall Programs:
Control Panel\Programs\Programs and Features

Then right-click on these to Uninstall, but choose the "Repair" option instead of uninstall.
Capture1.JPG

I did the Repair on both the x86 and x64 versions, but I suspect I only needed to Repair the x64 version which Terragen uses.
After I did that Terragen 4.5.56 installed as normal.

Matt

Glad to hear that! Thanks for letting us know what the solution was.
Just because milk is white doesn't mean that clouds are made of milk.