Showstopper - can't open/save files anymore

Started by pokoy, July 29, 2021, 06:36:14 am

Previous topic - Next topic

pokoy

So this was a problem before, but it got worse for some reason.
Ever since TG4 was released, we have a problem opening and saving files, where both actions take minutes to complete, even for really small files like the TG default scene. Same for importing clip files, it takes 10 minutes for a 4kb file, for example. TG becomes unresponsive, CPU and RAM usage comes to a halt, the app hangs.

I tried everything to figure out what the problem was - local or network access, OS language settings, making sure the antivirus app is not in the way etc.
The problem was/is present on both Win7 and Win10, on 3 different machines with different MB/CPU/GPU setups. The only thing worth noting is that the Win10 installs were upgrades from Win7, not fresh installs.

In the past I had to wait 10-15 minutes for a file to open or save. Once a file was saved for the first time from TG, subsequent save actions were OK and took only a few seconds. When TG was restarted, the first save would take minutes again.

For some reason it got worse now, to the point where I can't open or save a file anymore - I'm on TG 4.5.60

The ONLY way to open a file is to double click it - it will open instantly. But anything involving the file open/save dialog will just send TG into a coma.
So I can open files instantly by double clicking them - no lag whatsoever. But I can't save it once I change anything. This makes working with TG impossible right now, and I really need to meet the deadline.

Another thing I noticed is that the Library will not work. When I click on the Library button TG shows exactly the same problematic behavior and hangs.

I would be really grateful for any support with this, I really need to get this resolved.

pokoy

Additonal note - TG 3 works perfectly, opening/saving files works fine, opening the library is instant.
Whatever it is, it's a problem with TG 4.

Dune

I just freshly installed win 10 on this new internet machine, reinstalled TG 4.5.60, and tried opening some files made last week. No problem over here, it all loads fast. Saves okay too.

pokoy

Yeah, it obviously is not a problem everyone is having - but it doesn't help those who do. There must be something that changed how files are accessed between TG3 and TG4, or whatever is causing it. I can't reinstall Win10 with all the programs only to test if the problem is gone, especially since it's a problem with TG only.

Here are some threads discussing the same problem:

https://planetside.co.uk/forums/index.php/topic,23504.0.html

https://planetside.co.uk/forums/index.php/topic,20962.0.html

https://planetside.co.uk/forums/index.php/topic,25692.0.html

https://planetside.co.uk/forums/index.php/topic,28993.0.html

This problem is going back a few years, yet we have no solution.

WAS

I do not have issues really saving a new file, it may pause a moment but saves. My files are stored on my larger HDD which is only 5200rpm so may explain pause for seek-write.

However, I do have issues opening files where sometimes they hang for close to a minute before loading. Same scenario as you TG doesn't actually seem to be doing anything. Not even HDD activity. This is the same with TGCs.

I do not use that janky ass library so can't comment on it. Just finding stuff seems glitchy and since I know where it all is on disk I see no reason to it really. I just checked it out and attempted to load a object and I hangs from the library even on a 200kb sphere. Loading same object from right click hangs a moment but not nearly as long.

pokoy

For me it's taking much more time. I got the patience to wait for a file to save today - more than 20 minutes. On other files, I didn't have the patience and quit TG.
However, once a file is saved, any subsequent save is immediate.

Oshyan mentioned in one of the threads that they suspect OS language settings but never made clear whether it got looked into or not.

I'm glad I found out that double clicking the TG file will open it immediately, that way I don't have to wait for it to open and only deal with the first save lags.
It's really frustrating. When you're on a deadline, you don't really have time to wait 30 minutes for a file to save when it's only 500 kb.

WAS

What sort of antivirus do you have? I am curious how it handles file access.

Dune

Yes, antivirus was something that came to mind too. A way around it could be to save a small file first (unless that also takes ages), or use render to disk, so that it's saved in the background. Unless that also hangs...

crisb

Hey guys,

I'll see if I can get any light shed on this issue. 

cheers all,

Cris.

pokoy

Quote from: WAS on July 29, 2021, 12:55:01 pmWhat sort of antivirus do you have? I am curious how it handles file access.

NOD32, but it's not the root of the problem, I completely disabled it and the issue still persist.



Quote from: Dune on July 30, 2021, 01:57:58 amYes, antivirus was something that came to mind too. A way around it could be to save a small file first (unless that also takes ages), or use render to disk, so that it's saved in the background. Unless that also hangs...

It's really only about saving TG files and clips. Saving image files, or files generated by nodes is no problem at all.



Quote from: crisb on July 30, 2021, 02:34:24 pmHey guys,

I'll see if I can get any light shed on this issue.

cheers all,

Cris.

Thank you. Last time I reported this, Matt offered to do a remote session so he could have a closer look at the internals of the system when TG hangs. I haven't got in touch with him to make it happen back then. However, feeling that the problem has gotten worse in recent versions, I'd definitely be up for some remote session.