Camera POV settings...

Started by choronr, May 02, 2008, 03:20:21 am

Previous topic - Next topic

choronr

I had the urge to re-create an old Terragen 0.09 image using TG2. I loaded the .ter into TG2; then, proceeded to look at the Terragen 0.09 camera settings and copied down the three numbers and applied them to the TG2 camera settings so I could get the same POV. This didn't work so I tried the 'Target' numbers; but, this didn't work either. There seems to be no correlation between the old and new Terragen camera settings. This is evident since there is no 'Fixed height above surface' setting in Terragen2.

Is there any way to get the same POV using TG2?

Oshyan

There are a number of possible explanations for this. Due to some UI issues TG2 and differences between it and TG 0.9, there are some easy to make mistakes that would definitely result in major differences.

First, the use of coordinates in TG2 and TG 0.9 is a bit different, and to add to the confusion in TG2 the coordinates are sometimes not labelled, as in the Camera node. In TG 0.9 Z is "up" (perpendicular to the terrain). In TG2 Y is "up". So you basically just have to switch the Z and Y values when copying between the two. The order they're listed in is the same, X, Y, Z (even though they're not labelled), so just put the Z value into the Y slot. This is the most likely source of your problem.

The scale is another thing that could get confused. If TG 0.9 is set to work in meters, as it is by default, then the scales should match as TG2 respects the scale definitions in .ter files. However if TG 0.9 was set to measure in Terrain Units, then it won't match up. There are radio buttons in the Rendering Control dialog to the right of the "camera" title which control the measurement mode. You can also tell what mode it's in by looking at the numbers for the camera placement - if they end in "m" (e.g. 3900.m) then it's in meters mode (as it needs to be to accurately translate position). Switch to Meters mode if it's in Terrain Units.

Last and least likely is that TG 0.9 wasn't operating on a full globe, it was just a finite, rectangular terrain, so depending on how you're positioning your loaded heightfield (at default 0,0 with left position, or at center position, etc.) the positioning might be offset. What you want is Left Position and 0,0 in the Heightfield Shader.

Also note that the camera in TG2 has no Target, so you'll need to use the Rotation settings. The "Head" coordinate (first on the left in TG 0.9) corresponds to the 2nd Rotation coordinate in TG2. "Pitch" corresponds to the 1st coordinate and so Bank of course corresponds to the last one.

I think one of those should explain and help you resolve your problem.

- Oshyan

choronr

Oshyan, thank you so much for taking the time to respond to this thread during these busy times for Planetside. I will follow your suggestions here and see how they work out and get back to you.

Bob