balls, well sphere and image mapping

Started by David Burnett, July 24, 2008, 12:43:10 pm

Previous topic - Next topic

David Burnett

July 24, 2008, 12:43:10 pm Last Edit: July 24, 2008, 12:53:45 pm by David Burnett
I seem to be having an issues with spheres and image mapping.
I create a sphere and use the default shader to add the same image as a colour and displacement map.
That image has been rendered up be a UV style image map, it looks like this.
[attach=1]

I then copy sphere that and move the copy to example 2,0,0 and render

If I use UV mapping on the image it appears to have a seam, maybe the stretched poles end up around the equator.
[attach=2]

If I use spherical mapping I get the right results but only if the sphere is at 0,0,0 (the left hand sphere)
[attach=3]

Is this what is supposed up happen ? It seems 'wrong' to me that a uv image that is right when mapped spherically
on a sphere gets different results where uv mapped to a sphere, and to have the spherical mapping mapped to world co-ordinates makes it close to useless :0).

Dave

Matt

"Object UV (if available)" is only useful for imported objects that have UV texture coordinates assigned. The built-in sphere does not have UV texture coordinates.

Spherical and cylindrical mappings are in world space (object space is not yet supported). You need to set the centre of the projection (the "position" parameter in the image map shader).

Matt
Just because milk is white doesn't mean that clouds are made of milk.